Recent Posts

Pages: [1] 2 3 ... 10
System Utilities & File Management / Re: Keyquencer v2 anyone?
« Last post by 2DCC667B on Today at 02:57:45 AM »
I may be able to help, send me a PM thanks
just wondering if anyone here has ever even explored the possibility of a cheap pc serial addon card actually working for MAC OS 9?
with some type of 9pin serial to rs422 converter/adapter
Are there any difference of these M-Audio drivers and the ones on M-Audios site? Cause it appears under "legacy" in the driver/support download section you have drivers that are really really old?
True…some of my very best work goes down the shitter.
Mac OS 9 Booting on Previously Unsupported Hardware / Re: Building a custom Mac OS ROM.
« Last post by Daniel on January 17, 2019, 06:38:11 PM »
Vader, you got me thinking again about what can be found in the Darwin sources. Check this gem out:

It is a header describing much of the behaviour of a Mac OS 9 CPU Plugin!
The Plugin code in that directory also looks interesting. What Mac do you think it is for?
Good luck. I gotta go to the bathroom…

Just when things were getting good... one wonders what gems that Gary would have bestowed only to gone forever because nature called :(
I tried removing the preference files and get a message that I do not have permissions to do that (Yes, from OS9). So i booted into OS X and removed those preferences and then rebooted into OS 9, but still no help.

Interesting that it says I do not have permission. It is NOT locked according to the GET INFO panel. Weird. How can this be? It is the only account in OS 9. Why is OS 9 preventing me from removing those items? Granted, I did remove them using OS X, but that sounds like a clue.

I suspect you have, somewhere along the line, dragged or somehow interchanged a pref file to or from OSX. What??
What I mean is: In OS9, there are sharing permissions. In OSX, there are sharing and UNIX ownership permissions.
OSX can and does set and reset permissions all the time in ways that OS9 cannot comprehend.
There is a constant hazard with dual-boot systems where the disk utilities get to be at odds with each other.
I've recommended here many times to set both Time machine and Spotlight in OSX System Prefs to prevent them from accessing ANY OS9 volumes.
I have no idea exactly how you found yourself with an OS9 pref file that you lost ownership of in OS9 but since you were able to easily delete it in OSX it probably did become "owned" by OSX somehow.

What's important about that is that it was also unable to be changed, updated, revised in any way by OS9, meaning even if you could get the issue solved, the solution probably wouldn't stick.

Now: Let's go back to the actual, original problem.
You used to be able to access the network in OS9 - now you can't.
You used to be able to access the network in OSX - now you still can.

You said in the first post that this all "happened" when you tried to print to a networked printer.
I think it's more likely it happened before then and that's just when you noticed it.

Here's what you need to have working to reach your LAN (which is basically your router)
In the TCP/IP panel: Connect via Ethernet; Configure using DHCP server
  This should give you the same addresses as shown in OSX…router; subnet; IP address = same as in OSX
  YOU ALSO NEED: Active in System Extensions: Apple Enet; Open Transport 2.8.1 AND Open Transport ASLM Modules 2.8.1
  AND: Appletalk must be off.
  AND: An updateable TCP/IP Prefs file in System Preferences - After you check everything in the TCP/IP panel, this prefs file should show "Last date modified" as TODAY and the time

My best guess is Open transport is inactive…maybe……?

IF by some chance this works (it should, fingers crossed) The very next time you boot OSX, immediately go to System Preferences/Spotlight and prevent it from indexing the entire OS9 volume. Then do the same thing to Time Machine - select Do Not back up OS9 volume.

The objective is to keep all of the little UNIX-based notes Spotlight and TM write in the directory area of the volumes from confusing OS9, because eventually, OS9 Disk Utility will try to "repair" that stuff it doesn't understand (and it never heard of UNIX or OSX so it doesn't understand it). When that happens, the next time you boot OSX, IT will see the OS9 utility changes as errors and RE-fix it…then back and forth and back and forth until stuff is too corrupt to fix…period.

Spotlight and TM are the culprits - lock them out from the OS9 volume and everybody's happy.
Lastly, it's prudent to NOT just copy stuff from OSX to OS9 while in OSX. You're much better off booting OS9, then fetching those things from the OSX volume. That will help prevent permissions problems where you suddenly can't move or delete a file in OS9 that came from OSX.

Good luck. I gotta go to the bathroom…
DAW - Digital Audio Workstation General Discussions / Re: iMac g4 stealth port???
« Last post by FdB on January 17, 2019, 11:04:30 AM »
Ya gotta love this stuff!
(“Mother, being the necessity of invention” and all.)  ;)
Kudos to vectrex. That's the spirit!
Pages: [1] 2 3 ... 10