Author Topic: Getting Symantec C/C++ v8.6 on OS9 working?  (Read 3267 times)

Offline reeskm

  • Enthusiast Member (25+ Posts)
  • ***
  • Posts: 29
  • new to the forums
  • Liked:
  • Likes Given: 0
Getting Symantec C/C++ v8.6 on OS9 working?
« on: January 25, 2018, 11:43:57 AM »
Even though Metrowerks Code Warrior is the defacto standard for development on OS 8.6+, I wanted to try and get Symantec C/C++ v8.6 up and running properly because I found a lot of coding tutorials and books written for Symantec or THINK C/C++.

So, I got a copy from macintosh garden...

It is known not to work well with OS versions after 8.1, which was what was current when it was released.

So far I fixed one major show-stopper bug, but have another left:

1. When you open Cafe Studio, it complains that you haven't selected a printed from the chooser, and crashes right away.

Fix: Even though I don't have any printer, I fixed it by opening Chooser, selecting "LaserWriter8", and exiting Chooser.

2. In the Symantec Project Manager (the main IDE), it throws an error message when opening Project->Options... menu item.

"Couldn't complete the last command because a required resource is missing.

Result Code =-192"

Anybody have any ideas?

Offline Flk157

  • Member
  • Posts: 4
  • New Member
  • Liked:
  • Likes Given: 0
Re: Getting Symantec C/C++ v8.6 on OS9 working?
« Reply #1 on: January 01, 2023, 03:45:45 AM »
if it is not yet solved I had a similar problem. On OS 9.1 I needed to activate the Apple Guide system extension.
You will have another problem with the compiler. The change to OS 9.1 introduced a new Memory Management causing the compiler to stop with an internal error. (advice from


SimplePortal 2.3.6 © 2008-2014, SimplePortal