Mac OS 9 Discussion > Software

use Apple Disk Image format (.dmg .smi .img) packaging os9 files to move to osX

<< < (2/10) > >>

ok an update.. the file that i did readonly/compressed will not mount easily on X and now reports an error..  so i deleted the file from my user directory..
not sure why it had an error i think it was because i tried to mount it while it was on my afp fileshare (DUH) and not on my desktop and actual physical hard drive..  but i nuked the file already  ooops!

it seems that using diskutilty to do a restore from .img isnt going to work..
it seems easiest to just unstuff the .img from the .img.sitx (located in my user dir in the adrive ftp) and then after its extracted,
if you get any windows about username + passwords this may require u to go into system preferences -> accounts and click the lock in bottom left corner to AUTHENTICATE
then simply double click the .img file to mount
and drag these files from mounted .img (on desktop in X) to a prepared partition (formatted mac os extended non-journalled w disk utility ahead of time)
after the files are done copying -> system preferences -> startup disk  and look for the folder with the 9 on it that says its on your target partition (look for the volume name that you named it, or "untitled")

ive just tested this and im rebooting into the freshdraginstall for the very first time ever!!
and im seeing the blue screen for new user "welcome" animation
but im skipping that so i did cmd-option escape to force quit the new user setup
which results in the glitch of the ui.. so i rebooted again using the button on the front of the mac
which on reboot gives me the screen "computer didnt shut down correctly" disk first aid check..
and im in the fresh drag install mac os background of 9.2.2!
its detected my usb keyboard + airport card right away
correcting my resolution using the apple menu -> control panels -> monitor control panel
checking "About this computer" shows now mac os rom 10.2.1
now changing network connetion under apple menu  -> control panels -> tcp/ip -> selecting "connect via ethernet built in"
now i mount my AFP file server apple menu -> chooser -> apple share -> enter server ip 192.168.x.x
and it finds my media volume and mounts it on the desktop (just like the root drive)
copying my hardware drivers :)
installing shrinkwrap
installed stuffit deluxe 703
installed a-dock
installed classilla, dragged icon shortcut to the a-dock
put sherlock icon on the a-dock
set forum as the home page in classilla
disabling sleep mode (due to freezing on my mdd due to 3rd party nec usb pci) control panel -> energy saver
installed ableton live 4.14 + authorized
installed m-audio delta driver for mac os 9.x
installed oms 2.3.8 (selected pcr oms document provided with edirol pcr keyboard as the current set up)
installed edirol pcr driver for usb midi keyboard

at the end of all this what i want to do is use diskUtility in X to create a .dmg of the mac os 9 partition and then this will be the mac os 9 install file..
and it will be very easy to install using the "Restore" from a .dmg to a partition technique in disk utility!!!!!!!!! and hopefully this will keep all program authorizations in working condition!

ok now that i have a working playable setup for ableton live.... before i go much further only to find out that it doesnt work.. i will now try to back up this system and do a restore to a different mac! using the methods i talked about above;)

for this.. ive cloned the drive not using carbon copy cloner (ccc) but with disk utility...
and its made a compressed dmg that came out to about 650mb (the full size of the install on the mac os 9 root volume partition was around 1gb)
im restoring it now to my quicksilver 933mhz overwriting the current mac os 9 install with the cloned one frm the mdd..
ive installed all similar hardware (it also has a delta card for a audio interface + connected the same edirol keyboard)
so i hope to boot into a functional mac os 9 with authorized ableton live + drivers working in one go!

i booted up using the disk utility restore method just fine but when i ran ableton it came up asking for serial number and showed the serial i had used before but a few characters were missing..
so clearly something wasnt duplicated 100% for the auth to work.....maybe its because the hard drive is a different size??? not sure why the auth didnt work

ok regardless of the auth i had to re-run the installers for the audio + midi interfaces . probably because of where they are connected pci slots usb ports are diferent etc etc
also had to re-setup oms setup but live v4 is happily playing midi from operator (in demo mode for testing midi + sound are working)

seems my goal of having a truly instant setup is a bit shortsighted;)
 i guess i will have to try carbon copy cloner now:/

i wonder if its the differences in hard drive size/different systemthat is making teh auth not work . i will only know if i try to overwrite the existing install ON THE SAME MACHINE from the back up
and see if it works seamlessly loading up with everyhtng activated still or not!

ran out of juice for day (this being human thing sucks man;) hehe)
so i will try more tomorrow .. im thinking carbon copy cloner will make it work!!! re keepin the auths working.
ive done this once before using ccc i think it worked fine but i remember itmesed somet hings up like being able to drag .sit files to expander. the icon woudlnt light up on drag, hold  + mouseover but maybe i just needed to 'rebuild the desktop file' to fix this... but yea having a universal install that i could just image to my macs and have cubase + pt + logic + all these vsts installed would be invaluable... i hate how long eveyrthing takes to installl !!!!!

ok guys my mission here continues.. after ive had some rest..
now theres two other apps i can try to use in X to image the os9 partition.
superduper or carbon copycloner
im sure theres even more but for now these are the two that im testing to see if theres any difference in being able to maintain software authorizations working when cloned
so im imaging the original freshdraginstall on the mdd now using super duper! and i will copy this file back to my afp fileshare... and then boot up the qs 933 in X and copy the super duped .dmg clone of the 9 drive and restore it and see if u ableton will will start without asking for serial!!

im thinking one of these has got to work..
wish me luck

ok so superduper only took under 3min to clone the entire 1gb drive to a .dmg
i installed carbon copy cloner 3.4.7 which was the version reccommended to use with tiger 10.4.11
im now imaging the drive a second time using the ccc software... so i will have two images to try.. one from each app

ok i just tried super duper and it failed too..
ableton comes up asking for serial on launch
i wonder why it cant clone the authorization
i will try ccc now just to be thorough but its not
looking like its going to work...

does anyone know of a disk cloning app that might give better success for Mac os 9?

carbon copy cloner didnt work either........
the previously authorized ableton came up asking for serial

i think it would work if i was restoring to the exact same machine...... but not to another machine with hardware differences
i dunno im angry. and stumped.. this sucks! i was hoping it would work


[0] Message Index

[#] Next page

[*] Previous page

Go to full version