Pages: 1 [2]   Go Down

Author Topic: MIDI Interfaces connecting via USB (without audio i/o)  (Read 73964 times)

part12studios

  • Gold Member
  • *****
  • Offline Offline
  • Posts: 447
  • new to the forums
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #20 on: November 06, 2016, 08:43:34 AM »

interesting i'll keep that in mind.   i don't trust the need of the beatstep to work though.. feels too unique to be worth chancing it..  but i may still get one though if one comes along cheap enough again..  i don't have any CV reliant stuff other than experimenting with expression values like modulation and such on some effects.. ones that support expression pedals..  that are otherwise non-midi devices

Thanks!
Caleb
Logged

knightshaft

  • Newcomer
  • *
  • Offline Offline
  • Posts: 7
  • new to the forums
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #21 on: February 22, 2017, 12:09:56 PM »

Drivers for the Motu FastLane can be found here:
http://www.motu.com/download/download_matching_downloads.html?product_id=16
OS 9 driver is the one titles 'FreeMIDI 1.48/USB MIDI Installer'
Logged

teroyk

  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 623
  • -
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #22 on: August 20, 2017, 03:20:14 PM »

Yamaha UX256 drivers found here:
http://download.yamaha.com/usb_midi/
Scroll down to the USB-MIDI Driver for Mac OS 8.6 - 9.2.2
It's universal driver version for Yamaha USB-devices, but it has also Patchbay control panel to UX256.
It should has also support for UX96, but not tested.
Logged

Syntho

  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 1325
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #23 on: October 07, 2017, 05:29:37 PM »

I have a Roland UM-1 interface. The Roland page lists to the OS9 driver, but it's a tgz file, and on the inside the files seem to have lost their resource forks or whatever. The installer is just a blank icon and won't open.
Logged

Protools5LEGuy

  • Global Moderator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 2765
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #24 on: October 19, 2017, 02:28:08 PM »

That white icon is a extension. And works.

Just drop it on your extensions folder and Mac OS9 would not ask for a driver each time it boots

Logged
Looking for MacOS 9.2.4

Protools5LEGuy

  • Global Moderator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 2765
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #25 on: October 19, 2017, 02:35:45 PM »

To kill the UM-1 family trouble.  There is no installer. It is just an extension to drop on extensions folder. Once you drop and reboot it stop asking to search for drivers on internet.
Logged
Looking for MacOS 9.2.4

macStuff

  • Guest
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #26 on: October 20, 2017, 05:36:33 PM »

To kill the UM-1 family trouble.

there is an installer and it can be downloaded here:
there is seperate installers/settings for freemidi vs oms
http://macos9lives.com/smforum/index.php/topic,3612.msg27363.html#msg27363
Logged

macStuff

  • Guest
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #27 on: November 07, 2017, 12:14:09 PM »

I have the Midisport 8x8.  It is great since there are drivers that span from OS9 using OMS (USB on a G3) up until my current OSX 10.8.5.  I never was able to get the serial port to work under OS9 or 8.6.

hmm that doesnt sound right.. the midisport 8x8 should work as far as i know.. the original 8x8/s was released in 2001 i believe? or late 2000? MacOS9 was new + very much the standard mac os at the time... so it MUST WORK! perhaps they made different revisions of the Midisport 8x8 unit.. after about 2004? when all the support for os9 dwindled out of existance after hanging on for 2 years since the "steve jobs funeral"

are there any other midisport 8x8 owners out there?

ok wait im misunderstanding your post.. you said u never got it to work WITH THE SERIAL PORT
under mac os 9.... so i guess that means that it worked fine using the USB port? that doesnt make much logical sense tho either... using which mac model? were you using a modem-serial adapter?

« Last Edit: November 07, 2017, 01:38:35 PM by macStuff »
Logged

macStuff

  • Guest
original midiman midisport 8x8/s driver
« Reply #28 on: November 07, 2017, 01:37:51 PM »

heres a "driver file" retrieved from the web archive for midiman.net
https://web.archive.org/web/*/http://www.midiman.net:80/drivers/*

to be used with oms 2.3.7 or higher? (also attached)

the file is dated (June 1999)

heres an even earlier version: (104)
https://web.archive.org/web/20000819132953/http://www.midiman.net:80/drivers/usbmac104.sea.hqx
this version contains the original 1.0 driver i think aswell as the 1.04 driver aswell as a "loader" file? and   something called a usb shim? i think these files are for use with OMS
« Last Edit: November 07, 2017, 02:31:42 PM by macStuff »
Logged

user2020

  • Newcomer
  • *
  • Offline Offline
  • Posts: 6
  • New Member
Re: os9 Compatible Midi Interfaces (without audio capabilities)
« Reply #29 on: June 17, 2020, 04:39:45 AM »

I see. But as I wrote, I can confirm that the new Green/Black "anniversery" 2x2 interface works on OS9.
My friend uses this with his MDD without any problems at all.

I would be very interested in hearing how he got it to work, because it certainly doesn't work with my Anniversary Edition and the driver offered in the M-Audio driver thread.
Logged

refinery

  • Gold Member
  • *****
  • Offline Offline
  • Posts: 396
Re: os9 Compatible Midi Interfaces (without audio capabilities)
« Reply #30 on: June 17, 2020, 07:24:14 PM »

I would be very interested in hearing how he got it to work, because it certainly doesn't work with my Anniversary Edition and the driver offered in the M-Audio driver thread.

I seem to recall the problem with the anniversary editions was that the hardware changed at some point during its production, and it was a dice roll if you got one that worked with OS9. the "surefire" way to get a working one was to find the grey/white/black version. Ive got one of those and its always worked great in both 9 and X.
Logged
got my mind on my scsi and my scsi on my mind

noah330

  • Newcomer
  • *
  • Offline Offline
  • Posts: 3
  • New Member
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #31 on: June 25, 2020, 03:39:47 PM »

I have a Digidesign MIDI IO (USB) that I replaced this week with the new MOTU 128 on my (OSX) PTHD Rig.

I can try the MIDI IO on OS9 as there are drivers available and post what I can learn.

The Opcode Studio 4 or Studio 5 (I would personally rather have 2 Studio 4s) are a great solution that I remember being rock solid back in the day.
Logged

Jackhead

  • Newcomer
  • *
  • Offline Offline
  • Posts: 5
  • New Member
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #32 on: February 11, 2023, 10:44:36 AM »

Does someone has the driver for the Yamaha UX16 for OS 9.22? There not on the product page from yamaha any more.
Logged

smilesdavis

  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 753
  • New Member
Re: MIDI Interfaces connecting via USB (without audio i/o)
« Reply #33 on: February 11, 2023, 09:19:16 PM »

steinberg usb-2-midi (midiman 2x2)
steinberg midex 3
emagic unitor 8
steinberg micromidi
motu fastlane usb

all work
Logged
Looking for: Steinberg Cubase MAC Standard/Score v1-5 & Cubase Audio v1, Cubase Audio v2 for, Cubase Audio v3 for DAE/TDM => complete or in parts
Pages: 1 [2]   Go Up
 

Recent Topics