Author Topic: OS 9 crashing on startup  (Read 1925 times)

Offline alphaTECH

  • Enthusiast Member
  • ***
  • Posts: 34
  • New Member
OS 9 crashing on startup
« on: April 26, 2023, 04:16:41 PM »
I've spent a good few hours troubleshooting this now and can't fix it. OS 9 is crashing at various points on startup. It can be anywhere from starting to load extensions, almost finishing loading extensions, or (if I get to the desktop) accessing the favourites menu. The fact that it does not happen consistently at any one point makes this all the more frustrating. Last thing I remember doing was installing Connectix DoubleTalk. One of the first things I did was disable DoubleTalk extensions and it's made zero difference. I can boot just fine in "safe mode" (all extensions disabled).

Does OS 9 keep a log I can look at to see what's causing it to shit itself?
« Last Edit: April 26, 2023, 04:36:22 PM by alphaTECH »

Offline FBz

  • Platinum Member
  • *****
  • Posts: 666
  • Fury-Fungus FdB/FBz
Re: OS 9 crashing on startup
« Reply #1 on: April 26, 2023, 07:59:08 PM »
IF the only last thing you can remember changing was the Connectix DoubleTalk installation AND disabling related extensions AND (any possible) control panels associated with it - failed to rectify the situation… then perhaps the best thing that you can do is to determine which version of Apple Hardware Test is suitable for whichever Mac you may have (which you failed to mention). Download that version and then run it to determine IF you’ve a possible hardware problem.

Otherwise… the time consuming and painstaking, process-of-elimination approach for determining which errant extension(s) or control panel(s) / settings, might be causing your problem(s)… is now on your to-do list.

Unless you can remember changing something else, prior to the problem(s).

If AHT reports no problems, then the problem lies within something else that you must have done. Provided that the machine was stable beforehand.

And while you’re at it… you might also compose a little “Members Introduction” post ( http://macos9lives.com/smforum/index.php/topic,1991.0.html ) to clue everyone in about yourself, your background / experience and whatever machine(s) that you might be using. This really serves others to possibly help you... when needed. ;)

Addendum: OH, and then there's this...
https://macintoshgarden.org/apps/conflict-catcher-9
Anybody even use this anymore? (In the last 20 years?)
« Last Edit: April 27, 2023, 12:16:20 AM by FBz »

Online ssp3

  • Platinum Member
  • *****
  • Posts: 718
Re: OS 9 crashing on startup
« Reply #2 on: April 27, 2023, 04:41:13 AM »
Addendum: OH, and then there's this...
https://macintoshgarden.org/apps/conflict-catcher-9
Anybody even use this anymore? (In the last 20 years?)

In all my 25+ Mac years - never! It's all done by hand here. :)

But what I do use extensively is this: https://macintoshgarden.org/apps/installer-observer-303
If you're not part of the solution, you're part of the problem.

Offline alphaTECH

  • Enthusiast Member
  • ***
  • Posts: 34
  • New Member
Re: OS 9 crashing on startup
« Reply #3 on: April 27, 2023, 01:50:32 PM »
IF the only last thing you can remember changing was the Connectix DoubleTalk installation AND disabling related extensions AND (any possible) control panels associated with it - failed to rectify the situation… then perhaps the best thing that you can do is to determine which version of Apple Hardware Test is suitable for whichever Mac you may have (which you failed to mention). Download that version and then run it to determine IF you’ve a possible hardware problem.

Otherwise… the time consuming and painstaking, process-of-elimination approach for determining which errant extension(s) or control panel(s) / settings, might be causing your problem(s)… is now on your to-do list.

Unless you can remember changing something else, prior to the problem(s).

If AHT reports no problems, then the problem lies within something else that you must have done. Provided that the machine was stable beforehand.

System started just fine before DoubleTalk was installed. A hardware test is not necessary. I'll take a proper crack at uninstalling DoubleTalk today.

Offline alphaTECH

  • Enthusiast Member
  • ***
  • Posts: 34
  • New Member
Re: OS 9 crashing on startup
« Reply #4 on: April 28, 2023, 02:26:15 PM »
This problem is getting more bizarre.

I booted from the OS 9 universal install CD, and my G4 locked up again!

I ran the Apple hardware test and got a VRAM error code: "disp/15/5". There's nothing wrong with my graphics output, however I do have this "red tint" issue on 3D applications, however I've seen that on multiple ATi graphics cards, and I've never heard of VRAM going bad over time.

I have a 9000 Pro and a 440 MX on the way.

UPDATE: Pulled out my SSD + adapter, removed my USB hub, issue still happens when booting from CD. Maybe my graphics card really has died? Doesn't quite explain why I can use the Mac just fine with extensions disabled, although maybe it's the ATi drivers trying to communicate with a dead part of the graphics card that is causing the lockups. I'll try disabling the drivers now.

UPDATE 2: Yup, that worked. Semi-dead video card locks up the entire computer when ATi extensions are enabled. Who woulda thought? Not true...

UPDATE 3: I found an old post with a guy who was having the same issue. Turns out reseating his video card was enough to get everything working again. Come to think of it, the actual last thing I did to my Mac was to swap my 7500 with a flashed FX 5200; it didn't work but that's beside the point. So I've just reseated my 7500 and everything is working again with all ATi extensions enabled. Whew.
« Last Edit: April 28, 2023, 05:13:51 PM by alphaTECH »

Offline DieHard

  • Global Moderator
  • Platinum Member
  • *****
  • Posts: 2373
Re: OS 9 crashing on startup
« Reply #5 on: April 28, 2023, 05:35:11 PM »
Don't just re-seat it, use electronic cleaner and or eraser and clean the card's gold connector.

But keep a spare video card around, because once you start getting VRAM error (video memory) the card is most likely going bad, there is also a 2% chance your AGP slot has an issue.

Offline alphaTECH

  • Enthusiast Member
  • ***
  • Posts: 34
  • New Member
Re: OS 9 crashing on startup
« Reply #6 on: April 28, 2023, 06:19:03 PM »
Don't just re-seat it, use electronic cleaner and or eraser and clean the card's gold connector.

But keep a spare video card around, because once you start getting VRAM error (video memory) the card is most likely going bad, there is also a 2% chance your AGP slot has an issue.

I've always found that once I start dicking around with my hardware like that, there's a good chance it just makes things worse. I've been a technician for many years and have learned to leave well enough alone: if you start imagining problems that need to be fixed, you start creating problems that need to be fixed.

Offline DieHard

  • Global Moderator
  • Platinum Member
  • *****
  • Posts: 2373
Re: OS 9 crashing on startup
« Reply #7 on: April 28, 2023, 06:47:39 PM »
Quote
I've always found that once I start dicking around with my hardware like that, there's a good chance it just makes things worse. I've been a technician for many years and have learned to leave well enough alone: if you start imagining problems that need to be fixed, you start creating problems that need to be fixed.

Totally understandable, but the error you saw was NOT imagined, the AHT is a very good tool, if it showed VRAM errors, then you most likely have a flaky Video card, that being said, just replace it when it Fails to function for you

Offline alphaTECH

  • Enthusiast Member
  • ***
  • Posts: 34
  • New Member
Re: OS 9 crashing on startup
« Reply #8 on: April 29, 2023, 05:00:10 PM »
I'll run AHT again just out of curiosity and see if the VRAM errors persist.

UPDATE: They don't, the VRAM fault has gone away.
« Last Edit: April 30, 2023, 03:30:33 AM by alphaTECH »

Offline DieHard

  • Global Moderator
  • Platinum Member
  • *****
  • Posts: 2373
Re: OS 9 crashing on startup
« Reply #9 on: November 13, 2023, 08:28:24 PM »
I'll run AHT again just out of curiosity and see if the VRAM errors persist.

UPDATE: They don't, the VRAM fault has gone away.

Wow... ECC Video RAM, that is a new one one me... but I am not complaining :)

Offline alphaTECH

  • Enthusiast Member
  • ***
  • Posts: 34
  • New Member
Re: OS 9 crashing on startup
« Reply #10 on: November 14, 2023, 09:21:38 PM »
Nah the problem was the video card wasn't properly seated, it was half out of the socket on one side, if I'm remembering right. One of those clown moments.