Author Topic: connect3D radeon 9200 flashing  (Read 507 times)

Offline saturnu

  • Member
  • Posts: 4
  • New Member
  • Liked:
  • Likes Given: 0
connect3D radeon 9200 flashing
« on: September 04, 2022, 05:32:05 AM »

i just want to share some highres pictures and experience for potential 9200 buyers.
currently my Power Mac G4 is running with a radeon 9800 pro 128MB.
I wanted to "downgrade" the gpu for OS 9 2d/3d accel, so i bought a connect3d 9200 pc edition 128MB for 6,99 at ebay to flash it into a mac edition.

i booted into osx tiger 10.4.11 and enabled the onboard vnc server.
then i downloaded Graphiccelerator e.g. from

now i installed the agp card and connected via vnc to the power mac.
i went into the ati subfolder and started the "run this first" app, after this i started the ati dumper and checked the file size of the dump.
it was a 128kb rom dump, so i guess is was lucky, that i don't have to hassle with reduced roms.

after that i grabbed two roms at the usual place
Original ATI PPC ROMs
Retail   Radeon 9200   127   PCI & AGP 2x/4x/8x   250/200 MHz   128MB TSOP DDR   128KB
Retail   Radeon 9200   201   PCI & AGP 2x/4x/8x   250/200 MHz   128MB TSOP DDR   128KB

get the roms here:

first i tried the 201 rom, attached it to the flasher and run it. - the flasher warned me that the device id could change from 0x5961 to 0x5960.
the vnc connection just froze up and i could not reconnect, bummer...

after a reboot i tried the 127 rom and the flasher just asked if it should start the flash progress.
...and that's all, i rebooted the system and the picture came up.
no resistor mods, nothing....

keep in mind, that you have to tape some agp pins in macs with adc to use it with the 9200
this just wasn't the case with my sawtooth


SimplePortal 2.3.6 © 2008-2014, SimplePortal