Has anybody tried booting the image from a USB flash disk?
My Mini's optical drive is hosed, so I took a USB stick, made an Apple partition map on it, and flashed Ross's disk image to it. Then I booted into Open Firmware and typed:
boot usb0/disk:10,\System%20Folder\Mac%20OS%20ROM
However I'm not getting further than the floppy disk icon with a flashing question mark. Has anybody successfully booted this from USB?
EDIT: I got it to work. Here's what I did in case anyone wants to install OS 9 with a USB stick on a Mac Mini with a faulty CD drive:
1 - Prep the USB stick from another Mac:From another Mac, get an iso of the Mac OS X Tiger Install DVD, and Ross's OS 9 iso.
Using Disk Utility, re-partition your USB stick and make sure the partition scheme is "Apple"
Flash the Tiger DVD iso to your USB stick with Disk Utility's "Restore" functionality. Take note of the partition number on the USB stick (such as "disk1s3").
Finally, copy "Macintosh HD.img" from Ross's iso onto the USB stick.
2 - Boot the Mini to the Tiger installer via USB:Plug the stick into the Mini. Press the power button and hold down Cmd+Alt+O+F to bring up Open Firmware, and run this:
boot usb0/disk:3,\\:tbxi
You may need to use usb1 instead, depending on the USB port you're using for the flash drive. Also, replace "3" with the partition number you got when prepping the USB drive.
Wait for the Tiger installer to start up, then pick your language.
3 - Set up OS 9 partition from within the Tiger installer environment:First, open Terminal.
Let's partition the Mini's hard drive
with OS 9 drivers!!! We must do this in the Terminal because the Disk Utility GUI does not show the option to write OS 9 drivers.
Here, I'm creating two partitions on disk0, since I intend to dual-boot OS 9 and Tiger. If you want to make your own partition scheme, just run "diskutil partitionDisk" to get more info about the command. Also, make sure that your Mini's internal hard drive is disk0 (with diskutil list).
diskutil partitionDisk disk0 2 OS9Drivers HFS+ Classic 40G "Journaled HFS+" Tiger 40G
Let's copy OS 9 system files to the Classic partition now.
The source parameter in the command below is the path to the Macintosh HD.img you copied to the USB stick earlier.
You don't need "-rebuild", but it's nice to have as it will trigger a rebuild of the desktop file when you boot OS 9 for the first time, which seems to be needed due to missing icons etc.
asr -source "/Volumes/Mac OS X Install DVD/Macintosh HD.img" -target "/Volumes/Classic" -noverify -rebuild -verbose
Finally, we need to "bless" OS 9's system folder.
bless --folder9 "/Volumes/Classic/System Folder" --use9 --bootBlockFile "/usr/share/misc/bootblockdata"
4 - OS 9 is now installed on the Mini's hard drive!If all you want is to run OS 9, just reboot, unplug your USB stick and OS 9 should work!
If you want to dual-boot with Tiger, you can do so while you're in the Tiger environment. Quit the terminal and click through the OS X installation wizard. Make sure you install OS X on the second partition. Then reboot.
When booting the mini, hold down Alt to pick a boot partition. I haven't gotten the OS X "Startup" pref pane to "see" the OS 9 install.
Sources that helped me get there:Open Firmware USB boot:
1 2 Commands:
bless1 bless bless2 asrHow to bless OS9 to make it work:
bless