Mac OS 9 Discussion > Mac OS 9, Hacks & Upgrades

Fresh install problems

(1/2) > >>


First time posting.

I have installed a fresh Mac OS 9.2 from this site on a G4 MDD FW400 power pc to run as the main OS, and noticed I am getting the flashing question mark folder / missing os icon at the start, after 1 minute it finds the boot partition and boots into OS 9.2. I am also noticing if I use a KMV Switch and switch to another computer for too long I cant get the keyboard and mouse too work when switching back, not happed before in Tiger. And now I have also noticed sleep never resumes, the Mac just hangs.

Is this a HDD issue do you think, and the drive is failing?

Tried a PRAM reset and a battery change and also checked for errors on the disk. I have also held down the option key on boot and it does the same where it spends a while looking for the OS so it can boot from it.

Any thoughts appreciated.

Have you had this MDD for very long… as in - are you aware of its’ operational history? Any new hardware attached internally or externally? (New PCI cards, network connection, video, etc.?)

Best practice when installing a new or fresh operating system is to take the machine down to its’ barest bones before the install: mouse, keyboard, video card, period. No unnecessary peripheral or external devices (or network) connected during the install and then add them back, one by one after the install, testing each one AS you add them back, for any problems as you go. Omit the KVM switch and only add it back after all else has “tested good” and stable.

And did you re-initialize / format / partition the hard drive with Drive Setup 1.9.2 or Drive Setup 2.1 before this fresh installation? Is it the original HD and no other HDs are present inside?

But perhaps even before all of the above… download, burn to CD and run Apple Hardware Test for the MDD. AHT Version 1.2.7 from here:  And then run it again perhaps, even after another “fresh” installation… even if everything checks out good with the installation.

AND if the condition of your current HD is that questionable (or especially tests questionable with AHT) there are many SSDs and suitable adapter bridges that are now very affordable and can easily boost performance and dependability.

Of course you might also try simply rebuilding the desktop AND or a PMU reset too. But I would definitely run AHT - regardless.

Stay tuned, others here might have other suggestions like "Blessing the System Folder". Good luck!  ;)

I also used to use my MDD with a KVM switch, a DVI-D Dual Link one from Aten with 10 slots IIRC. Never had issues with it.

I'd try replacing the HDD with an SSD + a Marvell-based adapter for the IDE slot to convert it to SATA. They work excellent on the MDD, more reliably than when I used a PCI SATA Card with the same SSD (SATA Card firmware isn't as good and thus cannot handle as many types of SSD, and even when it worked, it functioned at the same speed as the main IDE connections anyway, for whatever reason, which I benchmarked time and time again).

Replacing the HDD with an SSD may or may not solve your issue, but it would DEFINITELY improve EVERYTHING. Using HDDs simply SUCKS on ANY computer, and is a whole bag of hurt, especially when SSDs are dirty cheap and available, at least the likes of 128GB are cheap.

How many partitions do you have on your HDD? What is the size of each partition, and in what order are those partitions? (These things can matter.)
Finally, what program did you use to do all the partitioning? Which OS or OS version? Did you format them all as APM and HFS+, plain HFS or perhaps even JHFS+? (All of those work, but just curious.)

Is Mac OS 9 on the first partition on the drive?
I had this issue many years ago when installing Mac OS 9.2.2 when previously only OSX resided on my MDD. It got solved by resetting the PMU using the CUDA button.

Thanks to all those who have replied.

I have had the machine for over 10 years and have tried to use it as a resource for many projects but never really had the chance to get back into using a MDD due to other commitments. However it has always been a reliable computer and not faced any issues.

It's one WD Blue IDE/Pata drive (80GB) with one partition running at 7200rpm with a 8mb cache I believe.

I had the AHT Disc already with the system but soon realised I needed the .7 version not .6 when I was getting invalid memory address issues before boot. This however has made me discover two problems. 1. The dvd drive I used to burn OS 9.2 is broken and not working correctly and the dvd drive in the G4 is also broken.

So with that I have used an apple superdrive in both, this has resulted in me being able to boot the AHT and find no issues exist, but also press a fresh dvd of 9.2 and reinstall.

Now back to the original problem of not being able to find the boot disk, the time waiting has now reduced to 3 seconds of a flashing question mark folder. is that normal?

I have a iSCSI PCI card in the device and I'm wondering if it is seeking this first or that it is somehow delaying the startup? However, if I install Mac OS X Tiger it's straight to the apple logo and no searching for the drive so I'm guessing that rules it out because why if looking for the boot drive would the G4 decide to do things differently just based on the OS change?

I can only think that because the hard disk had Tiger on it the OS 9.2 utility cant see the full disk partitions and the os 9.2 Image is not located right at the start of the disk sector so its taking longer to find due to the wrong location on the Hard Drive. However, I cant confirm this as I don't have a IDE caddie to pop the disk in and analyse the disk on a different computer, unless there is software that can run on Os 9.2 to check the disk or terminal commands might work?

I have pulled the power and pressed the PMU button once as instructed this hasn't made any change, but should I have done this without the battery still inserted? and does the battery on board need replacing, how would I know?


[0] Message Index

[#] Next page

Go to full version