Pages: [1]   Go Down

Author Topic: Can't complete initial boot on Aluminum Powerbook 15" (5,2)  (Read 1238 times)

dada78641

  • Newcomer
  • *
  • Offline Offline
  • Posts: 1
  • New Member
Can't complete initial boot on Aluminum Powerbook 15" (5,2)
« on: January 05, 2024, 12:18:20 PM »

Hi everyone, I'm attempting to install 9.2.2 from the unsupported G4 image to my Aluminum Powerbook G4, and I'm very close to getting it to work, but unfortunately it seems to hang right before the boot completes.

Here's where it hangs:



If I boot with extensions disabled, it gets one pixel further along but still hangs despite that. The setup from disc worked absolutely fine.

I'm dual booting with Mac OS X 10.4 on the second partition. Installation worked perfectly. My nvram script (entered via the OF console) is this:

dev /cpus/PowerPC,G4@0
80010201 encode-int " cpu-version" property
device-end
dev /pci@F2000000/mac-io/i2s/i2s-a
" screamer" encode-string " compatible" property
device-end
" /" select-dev
0 " graphic-options" get-my-property 2drop !
unselect

Originally I only had the first device section, but that didn't work. I added the subsequent "dev" and "graphic-options" sections because I saw them posted by others.

Would anyone happen to know if there's something I could've missed, or something I could try to figure out what's wrong? I can still boot into Tiger just fine, at least.
Thanks for any ideas :)

edit: oh, wow, nevermind this whole topic. I'm sorry, I somehow just completely missed the part of the tutorial that says to remove "multi processing" before boot. Somehow I had decided that's something you're supposed to do after first boot, but I misread it. Goes to show you really need to read these things properly.

After moving multi processing to disabled extensions, the initial boot was able to complete no problem.  :-X
Logged

ssp3

  • Moderator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 823
Re: Can't complete initial boot on Aluminum Powerbook 15" (5,2)
« Reply #1 on: January 05, 2024, 02:14:01 PM »

Is the backlight adjustment working? Can you switch display resolutions and/or color depth?
I also don't think that screamer fix is needed with this machine.
Logged
If you're not part of the solution, you're part of the problem.

vaccinemedia

  • Valued Member
  • **
  • Offline Offline
  • Posts: 26
  • New Member
Re: Can't complete initial boot on Aluminum Powerbook 15" (5,2)
« Reply #2 on: January 06, 2024, 05:26:53 AM »

Have you also moved all of the ATI extensions too as per the instructions or can these be left in there? Also have you got working audio?
Logged

DieHard

  • Global Moderator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 2388
Re: Can't complete initial boot on Aluminum Powerbook 15" (5,2)
« Reply #3 on: January 06, 2024, 11:19:33 AM »

After a request from vaccinemedia, I have updated the original download page and added...

Quote
NOTE: This install WILL need extra steps for unsupported Powerbook G4s !
Powerbook G4 Users can look here: http://macos9lives.com/smforum/index.php?topic=4781.0

This will hopefully save time and research for Powerbook G4 users
Logged

vaccinemedia

  • Valued Member
  • **
  • Offline Offline
  • Posts: 26
  • New Member
Re: Can't complete initial boot on Aluminum Powerbook 15" (5,2)
« Reply #4 on: February 10, 2024, 10:15:39 AM »

When it hung at that point on my PowerBook G4 5,4 the solution was to simply move the nvidia extensions and the Multi-processing folder to the "EXtensions (disabled) folder. No need to touch the ATI ones :)
Logged
Pages: [1]   Go Up
 

Recent Topics