Author Topic: 2 Imac G3s bootup flashing folder but boots after HDD upgrade  (Read 987 times)

Offline my3awds

  • Newcomer
  • *
  • Posts: 3
  • New Member
2 Imac G3s bootup flashing folder but boots after HDD upgrade
« on: September 28, 2023, 10:05:37 AM »
Hi I'm new to macs, but started a collection of Imac G3s.  All seem to be running fine, except I noticed the following on 2 of my machines that I've swapped hard drives for after a fresh install of 9.2.2 lives extended.

Imac 1 600mhz: installed a sata 60gb with a master/slave selectable pata/sata adapter from amazon (partition 1 is 7gb).  After installing the OS it boots fine, but it shows the flashing folder initially for 10-15 seconds, and the system I'm guessing is trying to find the new location of the OS.  Eventually it boots fine.  I've tried PRAM reset several times but no go.  Also gone into Startup Disk to select the appropriate folder, but same results.

Imac 2 233mhz: installed the original 20gb ide from the above machine and did a fresh install of 9.2.2 lives.  I notice the same flashing folder but only for 3-5 seconds and then boots normally.  Also tried resetting PRAm but no change.  If I put the old HDD back in, it boots fine without a flashing folder.  Which tells me that maybe the boot rom (?) is still looking for this exact drive.

I saw someone go into openfirmware and do a setenv command and not sure if that would be appropriate here?  Again, new to macs so not sure how to find the correct path and run the command properly from Openfirmware.  Both have the latest firmware done to them (in trying to resolve the issue) but the issue still remains.  Any help is appreciated!

Offline my3awds

  • Newcomer
  • *
  • Posts: 3
  • New Member
Re: 2 Imac G3s bootup flashing folder but boots after HDD upgrade
« Reply #1 on: September 29, 2023, 06:25:43 PM »
Looks like I inadvertently solved one of them lol.  On the 233, I reinstalled 9.2.2 from a cd instead of a USB, not sure if that made a difference, but after reinstalling 10.4.11 and then choosing 9.2.2 as the main OS, no more flashing folder.

The 1st Imac though, I'm wondering if there is no fix for this when using a Sata-Pata adapter?  Does anyone have a sata in a G3 with 9.2.2 and no flashing folder?  Maybe I need a specific brand adapter?  Thanks again....


Offline DrNo7

  • Enthusiast Member
  • ***
  • Posts: 79
Re: 2 Imac G3s bootup flashing folder but boots after HDD upgrade
« Reply #2 on: September 29, 2023, 10:12:44 PM »
Hi my3awds,

I am happy that using the CD solved the boot issue on one iMac. Maybe Apple Software Restore prefers CDs for some reasons or there was something off with your USB key setup (if you want to do some forensic, open Disk Utility on OS X and check the partition map type and partition types for theCD vs your USB key).

For the boot on the other iMac, there has been reports on this forum (and even tech explanations) about some no name adapters being with such a poor electrical section that cold booting would always be painful (as some 3.3V would take time to ramp-up to snuff). And a boot disk not available right away would explain the blink. The simplest way to confirm is to boot the machine (and deal with the blink) and then once on the desktop, trigger a reboot from the menu. If it is the adapter hating cold boots, it should smoothly reboot (no blink) as there is no interruptions in power for all devices. If it continues to blink, then the ghost hunt continues...
Ti 1 GHz / 1 GB / FW SSD / Airport Extreme PCMCIA (triple boot)
Alu 12 1.5GHz / 1.5 GB / 256 GB mSata SSD (dual boot for now)

Offline FBz

  • Platinum Member
  • *****
  • Posts: 666
  • Fury-Fungus FdB/FBz
Re: 2 Imac G3s bootup flashing folder but boots after HDD upgrade
« Reply #3 on: September 30, 2023, 08:12:13 AM »
Thank you DrNo7!

Likely the best description / explanation of similar problems I encounter with the 44-pin, MCA004 V1.3 adapters in the G4 Mac mini.
They will not cold boot the Mini - but after booting from CD, they will then reboot successfully with the MCA004 V1.3 adapters.
(I’ve different voltage regulators to replace & test with the MCA004 adapters, which I intend to attempt this winter.)

“For the boot on the other iMac, there has been reports on this forum (and even tech explanations) about some no name adapters being with such a poor electrical section that cold booting would always be painful (as some 3.3V would take time to ramp-up to snuff). And a boot disk not available right away would explain the blink. The simplest way to confirm is to boot the machine (and deal with the blink) and then once on the desktop, trigger a reboot from the menu. If it is the adapter hating cold boots, it should smoothly reboot (no blink) as there is no interruptions in power for all devices. If it continues to blink, then the ghost hunt continues…” -DrNo7

Might read through this thread http://macos9lives.com/smforum/index.php/topic,5436.msg39965.html#msg39965 /primarily concerning 40-pin adapters.

Have tested & used the green “Bribge” adapters (EVB-002-3) the StarTech & Addonics / AND the RXD-629A7-7 adapters… ALL, successfully in G3 iMacs here.

SO, which specific adapter… is my3awds currently attempting to use?
[A picture might be useful.] ;)

Offline my3awds

  • Newcomer
  • *
  • Posts: 3
  • New Member
Re: 2 Imac G3s bootup flashing folder but boots after HDD upgrade
« Reply #4 on: October 01, 2023, 12:53:51 PM »
Thank you for the helpful replies!  I recall why I never got to try installing from CD on this other imac, and it's because the optical drive doesn't like to read OR eject CDs lol.  I'm hoping that is in fact the issue and will try once I have time to find replacements for ALL of my slot loaders.
The Sata-Pata "NFHK" adapter I bought off of Amazon looks like the attachment, which seems to be a copy of the ADP-06 of your thread, FBz.  I will try installing via the CD first, and if that fails, I will try to install the image off of USB again, but without the optical drive connected to the IDE and messing with the master/slave/cable select jumper on the adapter.  Thanks again for the tips!