Pages: [1]   Go Down

Author Topic: Some icons are missing in 8.6 compared to 9.x  (Read 2629 times)

Knezzen

  • Administrator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 1055
  • Pro Tools Addict!
    • Macintosh Garden
Some icons are missing in 8.6 compared to 9.x
« on: April 28, 2024, 11:58:13 PM »

So I started to mess around with my PowerBook G3 Kanga running 8.6. I noticed that icons on some running applications are missing from the top right "application switcher" panel. The applications are there, but the icons are messed up or missing for some. Is this a "feature" of pre-9, or is something wrong with my system?
Logged
Pro Tools addict and admin at Mac OS 9 Lives!, System 7 Today and Macintosh Garden.

ssp3

  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 822
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #1 on: April 29, 2024, 12:00:08 AM »

Suggestions:
Nr. 1 - rebuild the bloody desktop!  ;D
Nr. 2 - check with ResEdit if the icon resources of smaller sizes are present.
Logged
If you're not part of the solution, you're part of the problem.

Knezzen

  • Administrator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 1055
  • Pro Tools Addict!
    • Macintosh Garden
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #2 on: April 29, 2024, 12:06:55 AM »

Suggestions:
Nr. 1 - rebuild the bloody desktop!  ;D
Nr. 2 - check with ResEdit if the icon resources of smaller sizes are present.

1 - I have :D
2 - I haven't, but the same applications look correct on 9.2.2 which confuses me. This is not about the icons in finder (they are correct), it's about the icons in the app switcher. Let me get a screenshot of it ;)
Logged
Pro Tools addict and admin at Mac OS 9 Lives!, System 7 Today and Macintosh Garden.

ssp3

  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 822
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #3 on: April 29, 2024, 12:22:02 AM »

Yes, I understood that. I still think it has something to do with resources. Got a download link for that particular Netscape Communicator?

Suggestion Nr.3 - trash Finder preferences, maybe Netscape preferences too.
Logged
If you're not part of the solution, you're part of the problem.

Knezzen

  • Administrator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 1055
  • Pro Tools Addict!
    • Macintosh Garden
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #4 on: April 29, 2024, 12:33:45 AM »

Some links:
http://macintoshgarden.org/apps/netscape-communicator-48
http://macintoshgarden.org/apps/hotstuff

The exact same binaries (I copied them over from the Kanga) show icons on my TiBook and MDD, both running 9.2.2.
Logged
Pro Tools addict and admin at Mac OS 9 Lives!, System 7 Today and Macintosh Garden.

Greystash

  • Gold Member
  • *****
  • Offline Offline
  • Posts: 235
  • Tinkerer
    • Mac-Classic.com
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #5 on: April 29, 2024, 01:10:01 AM »

Try switching color depths and see if that makes a difference. Perhaps OS 8.6 is using the icon resource at the current bit-depth but it's not present. Mac OS 9 may fall back to whatever is available?
Logged

Knezzen

  • Administrator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 1055
  • Pro Tools Addict!
    • Macintosh Garden
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #6 on: April 29, 2024, 01:14:14 AM »

Good idea, but that didn't change anything :(

Looks like I'm not the only one with this issue (or is it a feature?) historically.
https://macosx.com/threads/help-application-switcher-icon-missing.27983/
Logged
Pro Tools addict and admin at Mac OS 9 Lives!, System 7 Today and Macintosh Garden.

ssp3

  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 822
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #7 on: April 29, 2024, 01:57:59 AM »

Some links:
http://macintoshgarden.org/apps/netscape-communicator-48
http://macintoshgarden.org/apps/hotstuff

The exact same binaries (I copied them over from the Kanga) show icons on my TiBook and MDD, both running 9.2.2.

Sorry, that Communicator installer is broken. First it complains about missing preferences, then it expects floppies (or images) then it asks to insert my main drive.. I don't think I have time to troubleshoot it.
« Last Edit: April 29, 2024, 03:19:57 AM by ssp3 »
Logged
If you're not part of the solution, you're part of the problem.

Greystash

  • Gold Member
  • *****
  • Offline Offline
  • Posts: 235
  • Tinkerer
    • Mac-Classic.com
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #8 on: April 29, 2024, 02:00:06 AM »

Strange! I don't know what's wrong/incompatible with Netscape's icon resource, but I get the same results as you. However, after replacing its icon resources with another app's it displayed normally within the app switcher.
Logged

ssp3

  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 822
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #9 on: April 29, 2024, 02:06:37 AM »

Strange! I don't know what's wrong/incompatible with Netscape's icon resource, but I get the same results as you. However, after replacing its icon resources with another app's it displayed normally within the app switcher.

Icon masks?
Logged
If you're not part of the solution, you're part of the problem.

Knezzen

  • Administrator
  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 1055
  • Pro Tools Addict!
    • Macintosh Garden
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #10 on: April 29, 2024, 02:11:01 AM »

Strange! I don't know what's wrong/incompatible with Netscape's icon resource, but I get the same results as you. However, after replacing its icon resources with another app's it displayed normally within the app switcher.

Strange! Can you try HotStuff as well and see if you encounter the same issue as me with the scrambled icon?
Logged
Pro Tools addict and admin at Mac OS 9 Lives!, System 7 Today and Macintosh Garden.

Greystash

  • Gold Member
  • *****
  • Offline Offline
  • Posts: 235
  • Tinkerer
    • Mac-Classic.com
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #11 on: April 29, 2024, 03:29:46 AM »

Yeah it's scrambled for me too. Is this your app? Maybe it's got something to do with the software used to create the icon. I use Icon Machine for all of my icons and haven't had any issues with it. If you replace the icn resources with the attached file it fixes the scrambled icon
Logged

Jubadub

  • Gold Member
  • *****
  • Offline Offline
  • Posts: 396
  • New Member
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #12 on: April 29, 2024, 03:44:18 AM »

Icon Machine

Nice app! Great to see the Garden has it, too. Thanks for mentioning this!
Logged

ssp3

  • Platinum Member
  • *****
  • Offline Offline
  • Posts: 822
Re: Some icons are missing in 8.6 compared to 9.x
« Reply #13 on: April 29, 2024, 04:07:45 AM »

Yeah it's scrambled for me too.

Which version are you running? FAT or Carbon? IIRC, some icons related stuff is also inside data fork(s).
Logged
If you're not part of the solution, you're part of the problem.
Pages: [1]   Go Up
 

Recent Topics