Mac OS 9 Lives! (Classic Mac OS Forum)

Classic Mac Hardware (Troubleshooting, Upgrading, & Modifying) => Mac CPU Upgrades => Topic started by: MelTupper on April 04, 2021, 03:27:59 PM

Title: Frontal Lobotomy with SPD error
Post by: MelTupper on April 04, 2021, 03:27:59 PM
I recently performed a frontal lobotomy on my G4 (QS early 2002 M8666LL/A -please see screen shot for system details), by purchasing a very similar parts machine G4 on Ebay that had dual 1 Ghz processors on the daughter board (M8667LL/A). Grounded myself, never touched the RAM sticks in either machine, and swapped the daughter board and heatsink in the 'parts Mac' for the same parts in my G4. At first my G4 came down with a case of silicon lockjaw... froze on startup, time bombs, etc. Showed an extension conflict with MacPortrait driver, which I disabled. Zapped PRAM, ran Disk First Aid. Still freezing on startup. Ran DIMM First Aid which showed that my "DIMM checks out okay," but that the "SPD data revision is old or incorrect" on both RAM sticks. Prior to the double lobotomy day, I had no performance problems at all. What seems odd is that the problem is gradually getting better. Is it possible that the SPD modules (chips) on my RAM are learning how to behave from the new processors? Still getting the "Built in memory test has detected a problem" error on startup, so I turned off the startup memory test (it is annoying). Other symptoms like crashes and freezing have cleared, and performance is great aside from the memory test error. Everything looks normal in System Profiler. Ordered all-new 1.5 Gigs of new RAM, for good measure (it is on the way). Anybody have any idea what "SPD data revision is old or incorrect" means, or how it will effect life as I know it?
UPDATE: Turned off memory test and rebuilt the desktop today. Annoying error message is still there on startup.
Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on April 08, 2021, 02:00:15 AM
Anybody out there familiar with the app Dimm First Aid and error message "SPD data revision is old or incorrect?" Causing memory test error on startup. Thnx.
Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on April 13, 2021, 09:41:05 AM
Update: RAM upgrade today. Installed all new RAM 1.5 Gb. Still getting the annoying memory error message on startup. Suspect that this is a firmware issue. Need to learn how to upgrade firmware in OS 9.2.2.... Everything works flawlessly in 10.5.8 and 10.2, also installed on my G4.
Title: Re: Frontal Lobotomy with SPD error
Post by: FBz on April 13, 2021, 12:53:57 PM
Your firmware version 4.33f2 is fine. Of the 3 QS’es here:
an 867, a 1GHz, and a 1.67GHz (with a Sonnet processor
- thanks again Tugboat) they’re all 4.3.3f2. (Rev B boards)

Tarnish, oxidation and even corrosion inside the RAM slots is possible.
Check linked thread below for possible relevant measures… including
the Apple QS Diagnostic CD download AND Apple Hardware Test.
OS 9 seems a bit more sensitive about possible dirty RAM slots.

You could simply try switching the order of the sticks a few times,
as un-seating and re-seating the RAM can also improve connection.
But slot cleaning might be the next step. Unplug the machine and
press the power button several times to bleed remaining power
before carefully cleaning the slots with alcohol or contact cleaner.

After cleaning RAM slots… and running diagnostics, if problem
still persists, you might try a nice clean fresh install of OS 9.2.2. -
a la Hail Mary!

Is your QS motherboard a REV-A or REV-B?


Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on April 13, 2021, 07:08:09 PM
Hello, If the RAM slots were dirty or corroded (I did use air duster on them with new RAM install) wouldn't I also see errors in 10.5 and 10.2 which are installed on a partition and on another drive? Also, could you please elaborate a bit on the Motherboard revision? Not sure what you are driving at there. Is it supposed to be the same revision as the Daughterboard? Thnx!
Title: Re: Frontal Lobotomy with SPD error
Post by: FBz on April 14, 2021, 07:49:04 AM
By all means check the 4th screw (tight - good ground)
and for bent pins. And look for dust, etc. in the pin connections.

And... processor cleaned and fresh heatsink paste applied?


Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on April 16, 2021, 03:11:44 PM
Okay... Lots of revelations here, but I will try to keep this brief. Installed all new RAM, 3 identical sticks. Ran DIMM First Aid again, and the 'SPD data revision error' has cleared. New RAM checks out perfect. Which makes sense because the SPD chips went away when I removed the old RAM. Yet, the startup error persists: "The built in memory test has detected a problem with the cache memory." This was confounding because the startup memory test is set to "off" in the memory control panel. Compared the Boot ROM versions of both daughterboards, and they match (4.3.3f2). Did a CUDA reset. No luck. Reset the logic board board by unplugging power; removing clock battery; waited 20 min; replaced battery. No luck. Printed out system report in Leopard (10.5.8 installed on a separate hard drive) and under 'diagnostics' it tells me the Power On Self-Test (POST) failed, and the failure type is External Cache. Also in the Hardware Overview section the L3 Cache is made obvious by its own absence. It is supposed to show 2Mb of level 3 backside cache for this particular daughterboard/criminal brain. Okay... Frankenmac people, this is your moment! I did a bunch of reading today, and learned that the L3 chips can and do fail. But, there have been many successful similar lobotomies performed over the years too. There are ways to re-enable the L3 cache. One guy on a forum mentioned that he "was able to revive it with a small voltage bump." Wow! This is all getting very Shelley-esq... anybody know how to do a voltage bump or otherwise enable the L3 cache? Please don't tell me to climb to the top of a high tower and install a lightening rod.
Title: Shock the Monkey (QS L3 cache)?
Post by: FBz on April 17, 2021, 08:33:34 AM
Also after extensive searching here concerning this L3 malady, seems I’ve drawn a blank as well. Other than that one reference concerning the reported successful voltage jolt on an MDD.

Any other L3 Zappers here? “Speak up now or forever hold yer…”

But perhaps before you charge up the defribillator paddles, there is this - concerning the good ol’ leavin’ it alone approach (and trying it again, later).

“Well after reading your post and the subsequent replies I thought, hmmm, maybe it was a connection problem.
So I put my old DP 800 MHz card into the purchased machine and it started up and ran just fine.
Checking the Apple System Profiler I find the L3 Cache is there too!”

Might be interesting to also try yours, back in the original machine you bought for parts?
I still wonder about all of those little pins…

Some burn sage, or chant ancient Woz incantations. Others, simply wield hammers. But if you’ve considered these last-ditch approaches (and still maybe have some hair left)… I can offer you a tried, tested and true… 1GHz DP CPU (820-1324-A) in exchange for your Regan MacNeil model.


Lemme know. ;)
Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on April 18, 2021, 08:12:21 PM
Let me ask you this.... do you think that my old power supply might be too weak, and that the weakness of it might make the machine unable to recognize the L3 cache? I recently also added a Ti4600 graphics card, with (of course) its own cooling fan. Maybe between that and the dual processors there is just too much of a power drain. Appreciate your advice!
Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on April 19, 2021, 02:59:48 AM
Installed CPU Director in OS 9.2.2. (see attached). Also installed in 10.2.8 (see next post). Hope this info is useful in telling me what the heck the problem is and what I need to do. I was hoping that I would see the option to turn on the backside cache (L3 cache). Under the L tab the radio button for 'on' is selected, but also grayed-out... whatever that means. Enable cache is also selected but grayed out. Still looking for a way to tell my new dual CPUs to activate the L3 cache.
Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on April 19, 2021, 03:03:24 AM
CPU Director looks different in OS 10.2.8 (installed on partition on same drive). Please see attached.  No tab appears for L3, and under the profile page it shows that the backside cache for both processors is "Not present."
Title: Lobotomy
Post by: FBz on April 19, 2021, 08:41:02 AM
Considering the difference in power demands between your original QS 933 MHz(?)
with 256k "on chip" level 2 cache, and 2 MB of DDR SDRAM level 3 backside cache
compared to those of the QS 1 GHz DP with 256k "on chip" level 2 cache, and 2 MB
of DDR SDRAM level 3 backside cache?

Doubt they’re much different - but could probably dig up those exact specs.
OR others might have exact numbers. Still, more inclined to suspect bad,
bent or poor pin connection(s) / or failed L3 cache.

Old processor (933 MHz?) back in that machine, shows that L3 cache = OK?

Could try the power supply from your parts machine to test PSU theory.
You could also try the 1 GHz CPU back in that parts machine too.

Have you tried with previous video card installed, instead of new Ti 4600?
And also remove all but basic-function cards etc. to lower power demands.

Does the 933(?) CPU still work with your new Ti4600?

Are you using an older ADC powered Apple monitor?
(That’s up to 100 Watts.)

But now back to all those tiny connection pins…
there are tons of possible weak links there.
That’s Opti-visor (or higher magnification)
close visual inspection for bent pins.

Again however,
your L3 cache could simply just be toast.
Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on May 01, 2021, 04:23:47 PM
Never was able to get the L3 cache to function on that dual 1Ghz board. Concluded that the L3 chips were fried. Fbz shipped another similar board out to me (very kind of him!) Tried installing it today, and my Mac went straight into a default catch error and gray screen. The whole error read:

Default catch. code fffffff6 at %SRRO FF848148 %SRR1:0000B030
Welcome to Open Firmware
system time and date 00:3352 01/01/1904

To continue booting type "Mac-boot" and press return
To shut down type "shut-down" and press return

The problem was, I now had NO mouse function and NO keyboard function. (Both were plugged directly into the back of the Mac). So, I restarted. Now no chimes on restart, black screen. Totally dead in the water.

Have done some forum surfing today, and it sounds like I need to reset Open Firmware (NVRAM). Okay, well that's just cool and groovy. But how am I supposed to do that when the keyboard, mouse, and monitor are not functioning???

Anybody every seen an error like this before on a CPU upgrade? Wonder if the daughterboard might have the wrong chipset, or maybe the wrong firmware (boot ROM) version. How do I get my mouse, keyboard, and monitor to function again?
Title: Re: Frontal Lobotomy with SPD error
Post by: MelTupper on May 09, 2021, 01:46:40 PM
Okay, well I have to conclude that one of the CPU chips on board #2 is bad (thus the Default Catch error). I had started up the Mac a few times last weekend with it installed, and had no mouse or keyboard function, and a black screen on the monitor. I removed board #2 today, and when I went to clean the paste off of the chips, I discovered that the paste on one was still fresh and soft, but the paste on the other was baked on hard. That means obviously that one chip is working and the other is not. Next I installed another dual 1 Ghz board that I just got from DV Warehouse, and it went off without a snag. Basically just plug and play... so no problem with my motherboard or system. Also, moved my old single 933 Mhz DB into the PartsMac, and it too is working great now. Everything checks out. Anybody know someone who will test and repair the Criminal Brain for me for a reasonable price. I am thinking it needs the L3 chips replaced, but cannot be certain because I don't have testing equipment.
SimplePortal 2.3.6 © 2008-2014, SimplePortal