Author Topic: Geforce 2 MX PC board secret double life  (Read 1777 times)

Offline Protools5LEGuy

  • Global Moderator
  • Platinum Member
  • *****
  • Posts: 2079
Geforce 2 MX PC board secret double life
« on: April 15, 2014, 10:15:13 PM »
After 10 years been an Rage128 only user on PowerPC, I decided to get rid of that, at least on my DA.

I tried dozens of AGP cards and to my surprise my ASUS V7100(T) showed me a distorted happy mac/apple image.
The image was corrupted but it was recognized as a true Geforce 2 MX on OS9 and X.
I started to search and came to http://www.cybercoment.com/macgeforce.htm, a gold mine of info about flash PC GeForce (2, 3 and NOT 4) or Radeon 8500.
I was thinking on baking the card when I remembered that I had more PC geforces...
I tried with another but blank screen instead of corrupted image. I removed it and saw a little pin with two posible positions...
I thought..."What can I loose?" and put on the opposite position.
And BOOM working happy mac without distortions  ;D :D ;D :D
I tested it on OS9, and X and is supported everywhere. 
Perhaps for others Geforce 2MX is shit but for me are quicker redraws on the protools 5 mixer and Quartz Extreme for the first time on Powermacs.
Looking for MacOS 9.2.4

supernova777

  • Guest
Re: Geforce 2 MX PC board secret double life
« Reply #1 on: April 16, 2014, 02:38:00 AM »
really? a jumper fixed it? because i had the same thing happen to me when i was flashing my radeon 9250 pci..
and a radeon 7500 card.. same thing..  where are these jumpers?
can u show us?

nice work dude! :D

what did the distortions look like? lines? did u see lines?
« Last Edit: April 16, 2014, 07:04:19 AM by chrisNova777 »

Offline Protools5LEGuy

  • Global Moderator
  • Platinum Member
  • *****
  • Posts: 2079
Re: Geforce 2 MX PC board secret double life
« Reply #2 on: August 13, 2014, 01:55:04 PM »
really? a jumper fixed it?

what did the distortions look like? lines? did u see lines?


The one I installed that worked OK was an ASUS Geforce2MX Twin View with 64Mb with SVideo output and I am trying to make it work as twin view.

Searching some info found:
http://www.eden.net.nz/7/20011005geforce2mx.html
Quote
7 Attempts to get both monitor outputs on a PC-based NVIDIA GeForce2 MX twinview card working on a Mac
Quote
Current status: 14 July 2004 I received a message from Guillaume Thomas-Collignon today "I took your 1075 twinview ROM, 3.12 flasher, and I flashed a Inno3D GeforceMX400 64MB twinview card. It works perfectly, and the twinview is active if both monitors are connected during the boot. I have a G4 400 AGP (no gigabit) with a 1.4GHz CPU upgrade, running 10.3.4." So there you have it, once succesful report at least!

I had hooked the monitor via SVideo-Scart cable and it gives me a white image but just this. I am going to try the pins because maybe is NTSC instead PAL or something.

OS9 and OSX say it is a GeForce 2 MX Twin View
Looking for MacOS 9.2.4