Author Topic: OS 9 once worked and now doesn't?  (Read 4989 times)

Offline mgederberg

  • Member
  • Posts: 2
  • New Member
  • Liked:
  • Likes Given: 0
OS 9 once worked and now doesn't?
« on: November 23, 2022, 02:18:38 PM »
Alright so, another conundrum here. I've gotta G4 "Lampshade" iMac here... It's the 800 mHz 17" FP right? It WAS capable of booting into a partition with OS 9.2.2 until recently. It's like this, I can boot from the OS9Lives 9.2.2 Universal CD versions that I have burned but I cannot boot from an imaged FW HD that I had also been successfully using previously too. This is also true of OS X versions that I have tried with the exception of already installed OS X versions. I did find however that I can install from the OS9Lives CD and I can initialize the system disk, however that wipes the current contents for the 1 TB SSD I have in there and only formats as one 135 GB partition and it leaves no free space to use for any other partitions when I examine it booted from FW into an image of OS X. I even tried the actual Panther Restore Disks for this system from the Macintosh Repository and yeah it "seems" to successfully install, but when booting, I get the flashing floppy and System Folder for OS 9, that drops away and it chimes again when I reboot from OS X and set it as the OS 9 start up disk. The Boot Picker no longer ever shows an OS 9 volume like it used to. What could be going on here? Shall I futz around with an Open Firmware hack as a workaround?


Offline GaryN

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1516
  • active member
  • Liked:
  • Likes Given: 0
Re: OS 9 once worked and now doesn't?
« Reply #1 on: November 23, 2022, 03:29:21 PM »
First issue… I guess somebody around here is gonna havta fix this since it's becoming a regular thing.

So I rebooted into the MacOS9Lives CD to try to do DieHard's suggestion in the Disk Setup. It did not recognize the whole harddrive (only ~130GB), and did not offer me the option to install the necessary driver:

I am so sorry, apparently the "boot" part of out install has the older drive setup 1.92 (even though our 9.22 image has the newer 2.1 version), so don't use the one on the root of the CD when you boot, instead double click our drive image and navigate to the drive setup 2.1, that one will see the whole hard drive past 128GB...

Second issue:
I'm assuming you mean you were able to boot from the FW HD before it was imaged… when it was a "real" drive.
You can't boot from an imaged drive and System because the System has to boot in order to mount the image to find the System you're trying to boot from… Yup, it's a conundrum.

You should use the Panther Restore to setup and partition the 1TB drive, install OSX, install OS9 and bless the OS9 System folder then birdies should sing, flowers should bloom and all will be well………maybe

Offline FBz

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 643
  • Fury-Fungus FdB/FBz
  • Liked:
  • Likes Given: 160
Re: OS 9 once worked and now doesn't?
« Reply #2 on: November 24, 2022, 06:33:03 AM »
Download and use one of the following (instead of the Universal installer)

Drive Setup 1.92 and Drive Setup 2.1 are both present. Use DS 2.1 to format, partition and install OS 9
on your SSD and DS 1.9.2 for FW drives.

BUT FIRST… if the machine was working fine until recently, you might run AHT (or AppleCare TechTool Diagnostics)
to see if you’ve some other problem that caused the machine to falter in the first place?

AND there is also an iMac G4 2002 (Flat Panel) Restore download available here:,5907.0.html


SimplePortal 2.3.6 © 2008-2014, SimplePortal