Welcome Board (Our Community, News, Mac OS Installation Help, Marketplace) > HELP BOARD ! Installing & Troubleshooting the Classic Mac OS

iMac G3 freezes on file transfers

(1/2) > >>

Hi, I have recently acquired a 333MHz iMac G3 that does not like getting stuff copied onto itself...

I wanted to get some programs on via USB Thumb drive, so downloaded Classila and some games.
The USB gets recognised, opens in Finder... but when I want to transfer anything bigger, it copies few MBs and then the whole thing just freezes mid-way.
Not responding to any force-quit. Have to pull out the old paper clip...

Interestingly, I can process smaller files such as Wallpapers without any issue.
Also, even having the USB just plugged in is no problem, even if left it over longer period of time.

I initially thought it might perhaps somehow be running out of memory, so, have upgraded the RAM to 256 MB total (dedicated product by Offtek).

Also, the original owner has kept the HDD, so I now have a Kingston SSD (128GB, but properly partitioned etc.) and using hopefully a quality Sata/Pata adapter (same model as I've seen working on other G3 on the internet, with Master jumper and everything)

I have CDs for OS 8.5 and OS 9.1 and can install both of them no problemo. And the computer runs just fine and can be otherwise used without issues...

I thought there might be something wrong with the USB, so I spent quite some effort to get ethenet connection over to my new "retro corner". Once done, I wanted to download the same apps from MacRepository, but again - the computer freezes, this time mid-download.

I tried formatting the SSD several times in various way, even just with basic 6GB partition and everything else unassigned.
But not sure if SSD could be the problem...

Because where stuff gets weirds is that I got bunch of discs with e.g. MS Office or some Adobe tools, and can install those off of the CD just fine.

Has anyone experienced anything similar?
Or some ideas what could be wrong?


Maybe the reason you're not having issues with CDs is because when you install the software it's copying lots of small files rather than one big one, which seems to be the problem. You may have a bad adapter or perhaps your SSD isn't a good match. I've mostly used Apacer and Crucial SSDs in my G3s, G4s and haven't had any of those issues.

Some questions:
Is your SSD formatted as Mac OS Extended?
What does Disk First Aid say?
How did you originally format the SSD?
What happens if you try to make a disk image of a CD with Disk Copy?
When upgrading RAM did you remove the original sticks?
Have you tried installing the OS from another source? (different installer ISO/CD)

I've had exactly the same symptoms before, albeit on a SCSI OS8 machine.
The issue was narrowed down to a specfic hard disk (which appeared faultless in all diagnostic tests).
So I reckon it's the SSD.
You need another known working drive to copy the files to for comparison.

Thank you both!

I originally followed this guy - https://www.youtube.com/watch?v=pGvkKKWbx2I (minute 16).
Then did some alternative ways of formatting and partitioning, but now am back to this original setup.
No issues found in the Disk Aid.

I am expecting an OS X Panther CD in the mail later this week, so will see how that behaves.

If still bad, I will check on the Crucial SSD.
Any particular model that you can recommend as working?

Okay, so it was the SSD all time long!

Yesterday I was attempting to install the OS X and it froze again. So I've thrown in some old IDE HDD I found at work and voila, no more issues!

I still don't like the crunching noise and would like to have it as silent as possible (already upgraded the fan to one from Noctua) so would like to go back to SSD.

If you have any recommendation what works in the tray-loader, please let me know!

Thanks again :)


[0] Message Index

[#] Next page

Go to full version