Author Topic: WD My Book doesn't work with FW  (Read 7316 times)

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
WD My Book doesn't work with FW
« on: February 27, 2022, 08:18:15 AM »
Recently I bought a second hand WD My Book 2 TB with an LCD display and 3 ports: 1 USB and 2 FW800. It has a read-only partition (UDF) of 668 MB with the software and documentation.

This software says that it's a My Book Studio. The documentation says that it's a My Book Elite. It appears in Windows as a My Book 1112. I have no idea what it is.

I formatted it as HFS+ with MacDrive Pro. I can use it in OS 9 via USB but not FW. I think that this is caused by the UDF partition. I think that they used something to lie about the size of the disk. I can't even look at it with Parted Magic. It keeps scanning.

Is there a way to remove this UDF partition, would it continue to work, and would it work with FW in OS 9?

There's a lot of "solutions" on the internet that don't work. I would like to hear it from a serious person.

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #1 on: February 28, 2022, 07:30:55 AM »
Elite model has LCD display.

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #2 on: February 28, 2022, 07:36:45 AM »
Hereís the manual of the USB only model.

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #3 on: February 28, 2022, 07:41:18 AM »
They say that it requires OSX 10.4. It installs a 1394 driver which is called WD +TURBO.

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #4 on: February 28, 2022, 07:54:26 AM »
Hereís someone with the same problem, they have with USB what I have with FW:
https://macosx.com/threads/external-hard-drive-not-viewing-in-os-9-2.318000/

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #5 on: March 04, 2022, 08:50:09 AM »
I used the software for Windows to "hide" the virtual CD. Now I see something in Apple System Profiler, but itís not mounted.

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #6 on: March 05, 2022, 06:43:29 AM »
Well, this will be my lockable HD then, which is useful too.

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #7 on: March 05, 2022, 06:51:25 AM »
Hereís another nice story about WD My Book:

https://arstechnica.com/gadgets/2021/06/mass-data-wipe-in-my-book-devices-prompts-warning-from-western-digital/

Quote
GONE ó
ďIím totally screwed.Ē WD My Book Live users wake up to find their data deleted
Storage-device maker advises customers to unplug My Book Lives from the Internet ASAP.

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #8 on: March 06, 2022, 08:49:52 AM »
Summary of the problem: the controller is not USB or FW compliant.

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #9 on: March 06, 2022, 08:54:35 AM »
If I place the SATA disk in a different enclosure then it can be wiped.

What do you think of these enclosures:

Iomega MHNDHD - LAN/USB
LaCie D2 Quadra v2 - eSATA, Firewire 400/800, USB

Does the Iomega work with OS 9?
Does the LaCie work with OS 9 with FW?

Offline OS923

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 888
  • Liked:
  • Likes Given: 10
Re: WD My Book doesn't work with FW
« Reply #10 on: March 26, 2022, 12:22:06 PM »
I bought a Glyph GT 050Q of 250 GB. I swapped the internal disks.

Windows 10 didnít recognize the Glyph and it didnít show up in Disk Management.

Windows XP didnít recognize the Glyph but it showed up in Disk Management as unformatted. I formatted it. The special partition is gone. It works with OS 9 and FW.

The only thing that works now in the My Book is the power button. It keeps spinning, searching for the special partition.

If you want to keep the My Book enclosure, then donít delete the special partition.

Offline ssp3

  • Gold Member (200+ Posts)
  • *****
  • Posts: 217
  • Liked:
  • Likes Given: 28
Re: WD My Book doesn't work with FW
« Reply #11 on: February 05, 2023, 10:03:48 PM »
HA! I suspect the problem with your WD MyBook is that it has mandatory, transparent, full-disk encryption.
OS9 simply doesn't know what to do about it.
The encryption is performed by a Oxford Semiconductor chip on the USB-SATA bridge board and it can't be switched off by any common WD utility software. Password protected encryption on top of that is another story.
https://github.com/andlabs/reallymine/blob/master/_notes/story.md

If you're willing to experiment and don't mind to get your hands dirty, I may possibly help.
But first, post the hi-res pictures of the controller board (from both sides), so that the chip can be identified.

P.S. Are there any other WD MyBook firewire users out there?

EDIT: Attached are your MyBook manuals

Offline smilesdavis

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 624
  • New Member
  • Liked:
  • Likes Given: 17
Re: WD My Book doesn't work with FW
« Reply #12 on: February 06, 2023, 01:56:30 AM »
I have come to saying please scan both sides of the board
Looking for: Steinberg Cubase MAC Standard/Score v1-5 & Cubase Audio v1, Cubase Audio v2 for, Cubase Audio v3 for DAE/TDM => complete or in parts

Offline chrisNova777

  • Veteran Member (100+ Posts)
  • ****
  • Posts: 121
  • New Member
  • Liked:
  • Likes Given: 12
Re: WD My Book doesn't work with FW
« Reply #13 on: February 06, 2023, 05:32:41 AM »
macos9 doesnt support firewire 800
FireWire 800 requires OS 10.2.3 or above
https://apple.fandom.com/wiki/FireWire#:~:text=FireWire%20800%20(Apple's%20name%20for,pin%20connectors%20of%20FireWire%20400.
"in January 2003 Power Mac G4 was the first to require OS X. It was also the first with FireWire 800 ports."

anything that supports firewire 400 + sata should work in os9
i would urge you to consider simply relying on gigabit networking as it often out performs firewire
using a pc to install XigmaNAS would solve all your problems providing your able to give each client machine a gigabit ethernet connection
http://www.xigmanas.com it makes the whole machine into a server that supports many different types of connection over gigabit LAN then you could stop worrying about which drive enclosures are compatible at least and focus on providing yourself redundant fault tolerant storage

myBooks are incredibly flakey i have an 8TB drive and im not really happy with it i would not reccommend anyone else buy WD MYbook but there are alot of people who take the drives out of them because the enclosures are hit + miss performance wise but id rather just buy bare drives

Offline IIO

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 4106
  • just a number
  • Liked:
  • Likes Given: 244
Re: WD My Book doesn't work with FW
« Reply #14 on: February 06, 2023, 09:43:07 AM »

If you're willing to experiment and don't mind to get your hands dirty, I may possibly help.
But first, post the hi-res pictures of the controller board (from both sides), so that the chip can be identified.

P.S. Are there any other WD MyBook firewire users out there?


i think it is already alarming signal that the device requires a firewire driver under OSX. i have connected all my current disks via firewire 800 and none of them requires a driver.  all of them just work as is, from MacOS9 over OX to windows 10. i mean, it is a firewire disk, isnt it? :)

if there are chipsets or firmwares which do not work with OS9, we have to track that down for the sake of information, even if his disk already serves some belgian windows computer by now.
insert arbitrary signature here

Offline ssp3

  • Gold Member (200+ Posts)
  • *****
  • Posts: 217
  • Liked:
  • Likes Given: 28
Re: WD My Book doesn't work with FW
« Reply #15 on: February 06, 2023, 10:59:57 AM »
i think it is already alarming signal that the device requires a firewire driver under OSX.
It doesn't. Western Digital makes you believe that using their so called "WD+TURBO" driver is a good thing.

I suspect, the real reason, why WD created those drivers (several kexts), is that they attempted to fix drive performance issues created by using their "WD SmartWare", "WD Security" and "WD Drive Utilities", which include formatting, backup and password protection.

None of this stuff is needed for single drive WD Firewire enclosures to operate normally and should be deleted ASAP!

IMHO, WD's mandatory drive encryption on Studio/Passport FW models is as bad as PACE copy protection - it will screw you some day big time!  >:(

Quote
if there are chipsets or firmwares which do not work with OS9, we have to track that down for the sake of information, even if his disk already serves some belgian windows computer by now.

Shall we start a separate thread on this subject?

Offline IIO

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 4106
  • just a number
  • Liked:
  • Likes Given: 244
Re: WD My Book doesn't work with FW
« Reply #16 on: February 06, 2023, 11:15:31 AM »
okay, that explains it. it is for the extra stuff like that preformatted partition. iīve seen that with USB sticks, too.

i just figured that this thread is already 11 months old - ran into the davis trap once more.^^

new thread about "do all firewire controllers work with.." is fine, but i cant contribute anything useful to topics such as chips, firmware, and soldering.
insert arbitrary signature here

Offline ssp3

  • Gold Member (200+ Posts)
  • *****
  • Posts: 217
  • Liked:
  • Likes Given: 28
Re: WD My Book doesn't work with FW
« Reply #17 on: February 06, 2023, 01:54:06 PM »
okay, that explains it. it is for the extra stuff like that preformatted partition. iīve seen that with USB sticks, too.

That pre-formatted partition has different block size (2048 as opposed to 512) and is treated as CD image!

Information, how many sectors at the end of the drive should be reserved for the CD image, resides in WD MyBook firmware and is transparent to formatters, no matter what hard drive you connect to controller board - non WD, blank, SSDs etc.

Commands to mount this CD image are also in firmware and OSes will always attempt to do so, even if the drive is blank i.e. all zeroes.

WD drive lock/unlock etc. software is copied to those CD image sectors during manufacture and can only be run from there.

What's worse, that damned CD image takes away some disk space. I have WD MyBook Studio model 111D (aluminium enclosure) where CD partition is around 30MB, but, the one that OS923 has - 1112 takes away around 800MB and that's significant  >:(
How do I know that? I flashed 1112 firmware to my 111D just for kicks and found it out.  ;D They both have the same Oxford OXUF943 chip.
« Last Edit: February 06, 2023, 06:41:34 PM by ssp3 »

Offline ssp3

  • Gold Member (200+ Posts)
  • *****
  • Posts: 217
  • Liked:
  • Likes Given: 28
Re: WD My Book doesn't work with FW
« Reply #18 on: February 14, 2023, 11:21:28 PM »
Addition to my previous post. I'll leave it here for the information to be complete and in one place.
More general discussion about Firewire enclosures and chipsets that work in OS9 probably deserves a new thred.

This is how original 111D firmware reports to the system and various utilities. (OSX SL, sorry ;) ).
You can see the virtual CD and that its size is much smaller than that of a 1112 model.
All this on a controller board that has its hardware encryption deactivated and sectors on a hard drive corresponding to Virtual CD overwritten with zeroes, hence the CD doesn't show up on the Desktop. All done without the use of any kind of WD utilities.

The last two pics show how a particular sector of a same, regular drive - i.e. formatted with Disk Utility while being connected to a Mac via generic USB adapter, is seen by system when WD My Book Studio controller has its hardware encryption activated vs. deactivated.

Here's a link to horror story (-ies) related to WD MyBooks:
https://community.wd.com/t/wd-my-book-duo-data-forever-lost-if-drive-enclosure-dies/6496
« Last Edit: February 14, 2023, 11:57:59 PM by ssp3 »

 


SimplePortal 2.3.6 © 2008-2014, SimplePortal