Classic Mac OS Software (Discussions on Applications) > Virtual Machine & Emulation

In search for the elusive QEMU DAW System with working sound...

(1/2) > >>

From FdB...

--- Quote ---Understand there’s a “Sound” caveat that needs attention
but maybe the M-Audio Transit (or other similar USB device)
may eventually be implemented as a viable working solution?
--- End quote ---

From DieHard...

--- Quote ---The real challenge for our DAW members is to get QEMU for work with a USB Audio/MIDI device, I have not been successful :(
There are several "USB pass-thru" commands that will send USB device info into the emulator, then in theory, you could load the Mac OS 9 drivers, for the device and launch Logic, Cubase, or PT with sound !

I tried to get the M-Audio transit to work... it was recognized in OS9, but still did not function, I am hoping a member will find a usable USB audio device than we can port thru the emulator; for now QEMU is a silent world :(

There is a "screamer" version of QEMU that has system sound, but I have not found a working version of that either :(
--- End quote ---

We need to hunt down the right combination of ancient USB hardware, OS9 Drivers, QEMU USB passthru commands to achieve a working emulator that can actually become the world's first QEMU emulator with working DAW system.  I appear to any members that own both newer macs and older macs and Audio interfaces. 

I don't think there is a working Firewire pass-thru command for QEMU, but there has been luck with USB devices...
After getting the vendor and product id of the device (audio interface), add a similar command to the qemu.command script
-device usb-host,vendorid=0x16b2,productid=0x1001

Then load the drivers for the device is OS 9, I tried this with an M-Audio USB transit, it was seen in the OS9 system profiler, but the drivers did not work :(

I am hoping a member can come up with a working USB device is OS 9 and actually get CuBase, Logic, or PT to see it

i feel like dropping terms like "AVB" and, more important, "virtual audio driver" (blackhole, soundflower, jack, groundcontrol, XServe virtual audio device...)

Here’s a reference to QEMU “Screamer” Fork,
that I think you may have already mentioned as non-workable?

AND some other interesting commentary…

AND no, I’ve not yet returned to the initial QEMU install here (yet). :(

Some success with built in sound...

So I tried again, as I did months ago, the pre-built QEMU "screamer" versions that had some sort of built-in sound,
and I found one today that works on my 2009 Mac Pro, if the Core audio (in High Sierra) is set to Output -> Internal Speakers

The one I found that works is...
11-02-2020: Qemu 4.2 with screamer sound support. Built on Sierra

Found Here...

I am not sure why it failed prior, but I can now test things like PT free and Cubase report back :)

OK, I have made a major discovery, that I did not notice until today...

Setting "Virtual Memory" in Mac OS 9 to "Off" breaks the sound support in all "Screamer" pre-built versions of QEMU Power PC,
these are versions of QEMU that produce sound in the Mac OS 9 emulated machine

Unfortunately, many DAW applications like ProTools free will not open with "Virtual memory" turned on...

I believe this is why all my testing with Mac OS 9 and built-in sound failed in the past.  I can play an AIF file in QT with "Virtual Memory" on in Mac OS 9 and it plays thru the built-in speakers of my mac pro, simply turn "Virtual Memory" off is Mac OS9, reboot, and when trying to play the same file in Quicktime all hell breaks loose.


[0] Message Index

[#] Next page

Go to full version