Author Topic: the Reason>ReWire>Cubase Problems Investigation Thread!!  (Read 7663 times)

supernova777

  • Guest
the Reason>ReWire>Cubase Problems Investigation Thread!!
« on: January 29, 2014, 11:34:57 AM »

ok guys..
as some of u may know there was (& perhaps still can be?) major problems with rewire + Cubase.. and possibly other apps due to so many different versions of the rewire extension + associated files.
as u know.. rewire is a technology that gets added to our system folder upon installation of cubase, or reason or rebirth, or any other app that has rewire capabilities.. its really unfortunate the way they chose to do this "in the background" and never created an app of its own to control + keep track of the differences in versions + problems that could arise... but.. thats propellerheads for you. i have alot of respect for their innovations but i hold alot of grudges against them for some of their stupid decisions regarding the technology they invented!! but.. thats personal opinion.. and lets move on to the facts..

what im going to try to do is to do a clean system install and install different apps and keep track of the versions of the files that it installs.. and to test the use of rewire exporting...why would i want to do this you ask? well some rewire versions cause the audio exported to be slightly off at the beginning.. causing u to have to always use a 4 beat preroll before recording any audio - which is a TOTAL NUISANCE for me.. considering it is a background export process + not even a real time export..  it shouldnt be this difficult.. rewire is the best idea that never seems to work properly!! but perhaps there is more to this.. so lets look..

i will continue to update.. if you want to help, respond with which versions of rewire ext u have on your system, and what the performance is bouncing down audio via rewire with specific apps...

before we get started let me just detail my test spec:

G4 450mhz AGP Sawtooth
m-audio Delta 410 PCI soundcard
1GB ram 
Mac OS 9.2.2
w/ Cubase 4.1r2 Installed

first off let me just say that if my im not using cubase as one of my currently open + rewired apps, then i dont have any problems..
reason + ableton live for example seems to work 100% of the time together
reason v1.0 + live v1.0 work extremely well together.. cubase.. another story!! moving on..
i erased all rewire + reason files in extensions + prefs folders and proceed with the tests:

installed rebirth RB-338 v2.0 
>>> ReWire extension dated: Tue, Oct 20, 1998 8:44 PM v1.0
>>> ReBirth Engine extension dated: Thu, Oct 22, 1998, 10:18 AM v2.0
tested in cubase 4.1r2: Timing is perfect on exporting of rhythm patterns no kick drums cut off.. cubase + rebirth function 100% accurately + precisely without reason 1.0 installed

installed reason v1.0
>>> ReWire extension "Rewire 2.0.5" dated: Mon, Nov 20, 2000. 4:07 AM v1.2.5 (build 52)
>>> rex shared library extension dated: Mon, Nov 13, 2000, 8:11 PM v1.1.1 (build 17)
>>> reason engine extension dated: Wed, Nov 22, 2000, 7:15 AM v1.0 (build 78)
upon launching cubsae 4.1r2: "No More Mixer Channels!" error window presented
tested with cubase 4.1r2: reason v1.0 NONFUNCTIONAL, timelines not linked, reason starts in slave mode as it should but is nonfunctional, does not produce audio, does not visually appear to play upon pressing play on reason's transport, tempo shows 140 (while cubase is set to 120)
attempted to launch rebirth rb-338 v2.0 produced error: "You must enable ReBirth channels in Cubase VST:s ReWire panel before starting ReBirth" and program quits.
installed "Cubase Rewire Fix" extension to extensions folder, and REBOOT
now i launch cubase 4.1r2 i can see in my rewire panel the channels for reason have been limited to 16 instead of 64, so the rebirth channels can be seen once again below the reason channels in the rewire panel in cubase. relaunched reason while MIX L +MIX R rewire channels lit +active.... NONFUNCTIONAL.. reason will not play! next i tried rebirth... careful to activate the rewire channel ror MIX L + MIX R for rebirth (which are not clearly labeled as such but are below the first 16 channels for reason) launching rebirth RB-338 v2.0 rebirth is clearly at the wrong tempo 140bpm.. instead of 120bpm (which cubase is set to) howver changing the tempo in rebirth also changes tempo in cubase so they appear to be properly linked but doesnt initially start up properly and when u first press play, the first note seems to hold for too long a time and then it begins to play normally. this is everytime u press play.. there is this stutter or delay... this is with v1.2.5 rewire.. testing ableton 3.04 i get the error on launch: "Live Failed to install a newer version of the ReWire subsystem" and  then a 2nd error dialog saying "audio is disabled" and it says "The audio engine is off" at the bottom of Live's UI. Similar to Reason v1.0 the app will not play the main timeline.

there must be a solution to get reason v1.0 (without 1.0.1 update) to work with cubase rewire..... they worked on this.. they made it work.. perhaps its the cubase version itself that is breaking it? perhaps it works with the original 4.0? perhaps 4.1r2 was released WAY later on.. and thats why it doesnt work together?
checking the date of the cubase 4.1r2 executable reveals:
Fri, Jan 22, 1999, 4:47 PM
checking the date on the cubase 4.0 installer on the cd reveals:
Fri, Jul 31, 1998, 3:22 PM

you would think that between fri jan 22nd 1999 and the
ReWire extension dated: Mon, Nov 20, 2000. 4:07 AM v1.2.5 (build 52)
they had almost 2 years, all of 1999 + 2000..
during those years.. rewire must have worked??

of course there is no help to be found @ http://www.propellerheads.se/substance/rewirehelp/

http://www.soundonsound.com/sos/nov99/articles/rewire.htm
here is an article from november 1999...



installing reason 1.0.1

first off let me quote the document that comes with the install:
Quote
Welcome to Reason 1.0.1!

ReWire problems with Cubase
If you have Reason and Cubase VST installed on the same machine, please read the file "Read Me.txt" in the folder "ReWire Cubase Problems", which has been installed in the Reason program folder.

ReWire - Versions and Compatibility
When using Reason with ReWire, it is important to run the correct version of the ReWire "mixer  application" (the audio sequencer application into which Reason's audio channels are streamed). Also, please note that some mixer applications support ReWire 2 (streaming of MIDI data from the mixer application to Reason) while other support ReWire 1 (audio streaming only).

Steinberg Cubase VST for Windows:
Version 5.0 r4 or later (ReWire 2).

Steinberg Cubase VST for MacOS:
Version 4.1r2 supports ReWire 1.
In version 5.0, ReWire does not work properly, but as of this writing, a public beta version of 5.0r1 is available in which ReWire 2 support is included. Please go to www.cubase.net for details.

Steinberg Nuendo for Windows and MacOS:
Version 1.5 or later (ReWire 2).

Mark of the Unicorn Digital Performer:
Version 2.72 or later (ReWire 1).

Emagic Logic Audio for Windows and MacOS:
As of this writing, ReWire for Reason does not work in Logic. Emagic are aware of this problem and are working to implement ReWire in upcoming Logic versions. Please contact Emagic for more information.

source:
http://www.macos9lives.com/downloads/manuals/reason/reason_1.0.1_rewireInfo.rtf
http://www.macos9lives.com/downloads/manuals/reason/reason_1.01_whatsNew.pdf

installed reason v1.0.1
>>> ReWire extension dated: Wed, May 9, 2001 11:52AM v1.4 (build 60)
>>> reason engine extension dated: Fri, May 18, 2001 2:52 PM v1.0.1 (build 92)

running live 3.0.4
>>> ReWire extension dated: Tue, Jun 18, 2002 2:58 PM v1.4.7 (build 74)

installed reason v2.5
>>> ReWire Extension dated: Mon, Apr 7, 2003, 7:10 PM v1.4.7 (build 74) (Seems at this point they stopped updating the version info of the files properly)
« Last Edit: January 30, 2014, 05:52:49 PM by chrisNova777 »

supernova777

  • Guest
Re: the Reason>ReWire>Cubase Problems Investigation Thread!!
« Reply #1 on: January 30, 2014, 09:24:20 AM »
ok i think ive gotten to the bottom of this..
and the problem lies in the rewire channel configuration

to spell it out..
the problems with CUBASE + REWIRE start with the fact that with CUBASE
you have to ACTIVATE at least 1 ReWire channel *FOR THAT APP* before Launching the app.
i noted that i never have problems with using ReWire with Live & Reason.. thats becuase Live
doesnt have this silly requirement before launching the app.

Windows version of the panel: for illustration purposes only:

(you notice above it says "reason channel 1" etc for me, THIS IS NOT WHAT I SEE.. my channels are not labeled as reason or live etc)

Basically i've deduced that what was happening in my report above ^^
is that i was activated the MIX L + MIX R channels on Cubase's ReWire Panel..
but these channels did not coincide with REASON
I figured out that these were in fact the LIVE channels for rewire..
all this confusion could be so easily confused if the ReWire Channels were ***LABELLED CLEARLY + PROPERLLY**
but of course that would be too easy;)

so the real reason (heh) for the rewire problem was. not activating the proper rewire channel in cubase rewire panel, prior to launching the 2ndary app
the problem is, these channels are not labelled  in an explanative fashion (ie: they dont say live, or reason, or rebirth etc) they just say MIX L MIX R channel 3 channel 4 etc etc
the other problem is that there is a limit to these amount of these channels shown in the rewire panel in cubase 4 VST...
thats why there is this "CUBASE FIX" extension file that comes with reason 1.0 (inteded for use with cubase 4)
what this extension file does when u throw it in your extensions folder is limits the reason channels to 16 instead of 64, allowing you to see the other rewire channels for other apps (such as rebirth, live etc)

 but what happened in my case above is i think this "CUBASE FIX" adjusted the amount of channels for LIVE and not for REASON because i guess i had run LIVE first or something, or installed it first, and it took slot numero uno instead of reason.

ALL THIS CONFUSION COULD HAVE BEEN AVOIDED WITH A BETTER DESIGN OF THE REWIRE TECHNOLOGY ITSELF
the very fact that it works the way it does.. makes me want to slap the programmers @ propellerheads & steinberg for making this so unintuitive + hands off
theres no reason for all this crap. it should be easy to view + edit your rewire configuration, to set it up as u see fit, for seperate uses + seperate projects..

but as it is now, therse no way to edit this or control it..
so i must do a complete reinstall of my os now.. being very carefull to install programs in the right order so that i may end up with a proper rewire config...
i think the correct order to install would be:
cubase,
then reason,
then installing this "CUBASE FIX" extension,
verifying that the reason channels have been limited to 16
then rebirth,
then LIVE

Live has its own way of being able to limit the rewire channels
https://www.ableton.com/en/articles/optionstxt-file-live/

of course they omit any settings info for mac os 9..
because "mac os 9" had this elaborate funeral and all software developers pretend it never existed
« Last Edit: January 30, 2014, 09:30:10 AM by chrisNova777 »

supernova777

  • Guest
Re: the Reason>ReWire>Cubase Problems Investigation Thread!!
« Reply #2 on: January 30, 2014, 09:48:52 AM »

the following is translated with google translate from japanese document: http://www.h-resolution.com/pdf/pdf/Live_RW.pdf

ableton live Configuration changes ReWire function by option text
Here , with the option text is not displayed on the screen of the normal Live (non- operation ) is about ReWire
I will discuss any honors .
How to create a text option
In TextEdit , I create a text file name "Options.txt", the encoding "UTF-8" in the alphabetic characters .
By then save them enter alphabetic characters the command statement of purpose in the file of this text , and set the special Live.
Location of the text options
I will save (directory / the same path as the file "Preferences.cfg") at the following location: text option .
> (Live3 earlier ) Windows: folder Ableton Preference you have installed the Live
> Windows ( or later Live4): C: Documents and Settings user name Application Data
Ableton Live Preferences
> Mac OS 9: System Folder / default / Ableton
> Mac OS X: Users / username / Library / Preference / Ableton
* The user name is the user name you are currently logged .
It appears in the part of the gradient at the top of the by clicking the Start menu for Windows XP.
If you are using Mac OS X, it is displayed in (indicated by "shift +  + H" key while the window is opened ) Home folder
The name is .
* In the Windows system some , there may be times when you are hidden Application Data folder .
In that case , you can display the folder in the following operations .
In the case of Windows XP or 2000
I open the window 1) Explorer screen .
Select the Folder Options tool of 2 ) window from the (T) menu , and then click the View tab .
Put a check next to " Show hidden files and folders " 3 ) list .

i have just been writing to ableton support to get clear info ont his options text file.. but
it seems the info is here... is there already a folder named "Default" under "System Folder" on every mac os 9 system?
« Last Edit: January 30, 2014, 09:51:09 AM by chrisNova777 »

supernova777

  • Guest
Re: the Reason>ReWire>Cubase Problems Investigation Thread!!
« Reply #3 on: February 11, 2014, 11:03:09 AM »
my biggest complaint with rewire with steinberg products..
cubase specifically..

examine the pic,


this is using cubase LE v1.01 (from 2004-2006, based on cubase sx technology, upgrades from this product were directed to cubase sx3) on my windows 7 machine, but the results are the same on whatever cubase i use on whatever os i use..
the rewire sync is always just a bit off..

this doesnt happen to me if i use ableton + another app..
so it makes me think that steinberg are just
a bunch of goofs who cant get this technology to work right in every version of cubase prettty much since 2001.

BUT.. when i use NUENDO..
it seems that the rewire sync is much closer to bang on..
i cant figure it out..
if anyone knows any settings that actually can adjust the timing of the sync..
sigh

would be great technology tho. if it worked properly;)


for some reason when i use cubase rewire from ableton live.. things sometmes sync up properly
but not in this case.. duno if u can see at this zoome. but check the pic below
its off every beginning of every bar is off by a few ms

« Last Edit: February 11, 2014, 03:11:25 PM by chrisNova777 »

supernova777

  • Guest
Re: the Reason>ReWire>Cubase Problems Investigation Thread!!
« Reply #4 on: February 11, 2014, 03:09:01 PM »

heres a good pic on the difference of the offset.. the line on the right is where it was lining up
and now i nudged it by hand over to where it should start (so that snapped to grid audio includes beginning percussive part of the
kickdrum)

supernova777

  • Guest
Re: the Reason>ReWire>Cubase Problems Investigation Thread!!
« Reply #5 on: March 13, 2014, 11:50:49 AM »
would be really great if someday someone could explain how to cure this rewire offset problem

happens to me on os9, osx + windows all alike
maybe the only real answer is to avoid rewire, so to releive oneself of hte headache of always correcting this small offset