Author Topic: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem  (Read 1657 times)

Offline simondo3

  • Valued Member (10+ Posts)
  • **
  • Posts: 12
  • new to the forums
  • Liked:
  • Likes Given: 0
Hi OS9ers,

My Quicksilver PSU died recently so I bought a cheap well looked after G4 MDD 1.25 SP FW400 in order to move all my HDs and Pro Tools PCI cards to.

Now the main system drive from the Quicksilver has 3 partitions, OSX 10.3.9, OS9.2.2 and a DATA partition (non sys). I first changed the jumpers to cable select and installed it into the MDD. I booted into OSX no problems but when I try and boot into the OS9 partition I get the ? missing system sign. (This OS9 system ran great on the Quicksilver)

So I booted back into OSX and tried booting into the Classic Environment via Sys Prefs and I get a message saying:

"Classic needs to update files in system folder.......these files will not affect starting your computer from this system folder "

Now I am slightly worried I will mess up this OS9 System drive I have spent years and months configuring for music production, so thought I would check here and see what people here say about this issue.

Hopefully I can let OSX do its thing and it will install the files to make this MDD boot up the QS OS9 partition.

Not sure if I need to be connected to the internet in order for OSX to access these files though?

Anyway I hope you are all well and I look forward to some much needed advice

Regards

Simon


Offline GaryN

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1227
  • active member
  • Liked:
  • Likes Given: 0
Re: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem
« Reply #1 on: August 12, 2020, 03:14:53 PM »
You probably need to "bless" or in this case, "re-bless" your OS9 System.
Try this:
1. In OSX, open the OS9 System Folder.
2. Drag both the System and Finder out onto the desktop.
3. Stand up, turn around three times and cross fingers.
4. Put them back into the System Folder.
5. Reboot with the option key held down and see if OS9 appears.

Offline IIO

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 3048
  • just a number
  • Liked:
  • Likes Given: 61
Re: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem
« Reply #2 on: August 12, 2020, 03:16:56 PM »
the OS9 version is probably not sufficient for the MDD.

if you have one, install a fresh copy from an MDD installer CD (otherwise use our "universal" OS9), then move your controlpanels, extensions, protools plug-ins and preferences files over.

eventually make a safety backup of your old OS folder first. (you should always have one anyway)
insert arbitrary signature here

Offline simondo3

  • Valued Member (10+ Posts)
  • **
  • Posts: 12
  • new to the forums
  • Liked:
  • Likes Given: 0
Re: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem
« Reply #3 on: August 13, 2020, 01:22:20 PM »
Thanks Gary, tried that, literally  ;) no joy. When I start with the Option Key, I can see the OS9 partition and its got the system logo on it anyway so it seems to be blessed. On an Option key startup it takes ages (3-4 mins ish) for the OS9 partition to show up visibly and when it does I get a spinning ball for another couple of mins before I can finally select it to boot up, then I get the question mark..

I have a backup of this os9 sys to play about with so I tried pressing yes on the prompt to install the files in the classic environment, it started to boot then bombed out with:

"file system map inconsistent"

Tried rebooting it with extensions off, same thing. Thing is, this QS drive has 3 partitions and OSX is the first partition, I wonder if OS9 has to be the first partition to work on a MDD, sure I read that somewhere.

IOO....Yep I think I may have to do a clean install for the MDD, it's probably a good thing since i know a lot more about OS9 and Pro Tools TDM etc now than I did when I first installed this system years and years ago.

I wonder if this error ""file system map inconsistent" has anything to do with OSX being the first partition. Maybe I can clone onto another drive.

Offline GaryN

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1227
  • active member
  • Liked:
  • Likes Given: 0
Re: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem
« Reply #4 on: August 13, 2020, 01:45:39 PM »
OS9 does NOT have to be first or any particular place. I have an MDD with 5 volumes + 1 Time machine volume across 4 HDDs. Trust me…it don't matter.
The error message "file system map inconsistent" is telling you why you have the question mark, spinning ball etc. There is something wrong with (probably) the directory. I have no idea what that might be. Normally, you should be able to do exactly what you did: simply move the drive from one computer to another.

** You didn't try to "fix" OS9 with OSX Disk Utility,did you?

This is where you're supposed to boot OS9 from CD and run OS9 Disk Repair. If that doesn't work, then you save your existing OS9 System folder somewhere so you have saved any and all Extensions etc. and can put them back as they're supposed to be then install a new OS9 from scratch. Sometimes just a bit or two gets lost or corrupted and it's literally a needle in a haystack so the logical fix is to shotgun the whole install.

Offline IIO

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 3048
  • just a number
  • Liked:
  • Likes Given: 61
Re: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem
« Reply #5 on: August 13, 2020, 06:11:51 PM »
an MDD is simply not able to properly boot into the OS9 which came with the QS 2002 (or the 9.2.1. retail CDs) the other way round is no problem.

(i am not sure if the ROM and CPU software is all he needs? i have a juvenile, preinstalled universal system folder around for such cases)
insert arbitrary signature here

Offline simondo3

  • Valued Member (10+ Posts)
  • **
  • Posts: 12
  • new to the forums
  • Liked:
  • Likes Given: 0
Re: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem
« Reply #6 on: August 14, 2020, 02:14:17 AM »
I haven't messed with the OS9 partition at all with disk utility.

Yep, tried the various os9 installer CDs (9.2.1 and 9.04)  I had kicking around. All boot up but installers say cannot be used on this machine

So going to find that Universal os9 installer and install a fresh sys on this 80GB that came with the MDD (it had a 10.2.8 on it but no os9)

Thanks Gary, thanks IOO

Much appreciated

Offline macarone

  • Enthusiast Member (25+ Posts)
  • ***
  • Posts: 63
  • New Member
  • Liked:
  • Likes Given: 0
Re: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem
« Reply #7 on: August 14, 2020, 06:02:28 AM »
>I get a spinning ball for another couple of mins before I can finally select it to boot up, then I get the question mark..

That specific problem was answered here:

http://macos9lives.com/smforum/index.php/topic,4867.msg41338.html#msg41338:

"you can save some waiting time once the partition you want appears, by clicking the Mouse once and then Command-Period."

I don't recall the other problems being answered. If you figure it out, please DO let us all know!

Offline simondo3

  • Valued Member (10+ Posts)
  • **
  • Posts: 12
  • new to the forums
  • Liked:
  • Likes Given: 0
Re: G4 933 Quicksilver to G4 1.25 fw400 SP MDD system drive swap problem
« Reply #8 on: August 18, 2020, 06:08:47 AM »
I did a fresh install with the Universal installer. Moved all my Prefs, CP's and extensions over

Everything works a treat so thanks for your help Gary, IOO and mac