Author Topic: Cubase 5 needed(Plus link for sx3, 4 and 6)  (Read 642 times)

Offline Nandos0804

  • Active Member
  • **
  • Posts: 15
  • PPC lover
Cubase 5 needed(Plus link for sx3, 4 and 6)
« on: February 25, 2019, 02:20:21 AM »
Hi guys, i would like to know if someone has got a copy of the original Installation DVD for mac of Cubase 5 (the 2009 version). Those are the links for 6, sx 3 and 4 for mac, original and untouched. Thank you for your time!

ftp://ftp.steinberg.net/Archives/Cubase/Cubase_6_Trial.dmg

ftp://ftp.steinberg.net/Download/Cubase_SX_3/Cubase_SX_3_VST_Song_Conversion/Mac/SX3.1_CD_Installer_Mac.dmg

http://support.steinberg.de/ISOs/Cubase/Cubase_4.1.0.iso?fbclid=IwAR0nu6W_Hm7_2FAkPio-odh_Hgb-UvHblRBttM-wKfjgWSV8UNtqcYVqlv0

Offline Nandos0804

  • Active Member
  • **
  • Posts: 15
  • PPC lover
Re: Cubase 5 needed(Plus link for sx3, 4 and 6)
« Reply #1 on: March 05, 2019, 10:34:51 AM »
I just found it, hope that this could help someone

http://support.steinberg.de/ISOs/Cubase/Cubase_5.5.0.602.iso

Offline macStuff

  • Vault Members
  • Platinum Member
  • ***
  • Posts: 1060
Re: Cubase 5 needed(Plus link for sx3, 4 and 6)
« Reply #2 on: March 08, 2019, 11:47:11 PM »
you can find lots of info here that i made note of a few months ago:
http://www.oldschooldaw.com/forums/index.php/topic,5635.0.html
but this has basically nothing to do with macos9 as Cubase5 requires Leopard or SnowLeopard and really shouldnt be being discussed on this board.