Author Topic: sound diver troubles w MOTU?  (Read 3078 times)

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 84
sound diver troubles w MOTU?
« on: September 21, 2018, 12:57:53 AM »
hey guys,

i cannot for the life of me get sound diver to work right with my MOTU MTP AVs. the computer sees it, OMS sees it, OMS talks to each individual synth properly, it shows data being received on the correct ports... but Sound Diver constantly times out... I even see some of my synths say they are starting sysex transfers but the computer still freaks out. one thing ive noticed is that with these interfaces, Sound Diver doesnt let me select the specific input of a device if im using the MOTU driver.. it always says "any" in the Sound Diver input selection. Im wondering if there is some known incompatibility with these interfaces (which would be ironic, since i moved to them from Unitor 8s because the UN8 wont pass proper external midi clock)

it always, no matter what connection (tried both USB and serial) times out when trying to connect to the devices. as i mentioned previously, all other apps see the midi and work properly, so this is clearly a problem with sound diver itself.

just curious if there is some trick to this, or if there is some known incompatibility between the two.
i still have my unitor 8s, but, im reluctant to switch back to them for this because that just causes another problem somewhere else (external midi clock)
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline IIO

  • Platinum Member
  • *****
  • Posts: 2036
  • new to the forums
Re: sound diver troubles w MOTU?
« Reply #1 on: September 21, 2018, 07:34:28 AM »
sysex-in is turned on in your current OMS setup? it is filtered by default when i remember right.
"It is true that the "pre-emptive multitasking" advantage present in OS X can be illustrated by downloading CD-ROM ISOs and rendering chaos theory formulas while simultaneously instant messaging and posting on FaceBook what you ate... but in reality, what did you create?"
- DieHard, random forum troll at macos9lives.com

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 84
Re: sound diver troubles w MOTU?
« Reply #2 on: September 21, 2018, 02:39:44 PM »
im not familiar with that option.. any idea where that setting would be located?
or is this something that must be done with the MOTU options?
« Last Edit: September 21, 2018, 05:41:00 PM by refinery »
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline IIO

  • Platinum Member
  • *****
  • Posts: 2036
  • new to the forums
Re: sound diver troubles w MOTU?
« Reply #3 on: September 21, 2018, 05:53:28 PM »
oms setup ... per port
"It is true that the "pre-emptive multitasking" advantage present in OS X can be illustrated by downloading CD-ROM ISOs and rendering chaos theory formulas while simultaneously instant messaging and posting on FaceBook what you ate... but in reality, what did you create?"
- DieHard, random forum troll at macos9lives.com

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 84
Re: sound diver troubles w MOTU?
« Reply #4 on: September 22, 2018, 02:48:22 AM »
i dont see anything in the per-port editor regarding sysex filtering. am i looking in the wrong place?
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 84
Re: sound diver troubles w MOTU?
« Reply #5 on: September 22, 2018, 03:15:31 PM »
hrm. ive been doing a lot of research today and finding lots of problems from people trying to use these MOTUs with SD. im going to see about firing up my Unitor8s this weekend and see if the problem continues.
one interesting thing i did find is that the OS9 version of MOTU clockworks gives a lot more configuration options than the OSX version does. or at least makes it more readily accessible.
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline IIO

  • Platinum Member
  • *****
  • Posts: 2036
  • new to the forums
Re: sound diver troubles w MOTU?
« Reply #6 on: September 23, 2018, 02:28:26 AM »
hm, only mtc and clock... seems i remembered wrong.

"It is true that the "pre-emptive multitasking" advantage present in OS X can be illustrated by downloading CD-ROM ISOs and rendering chaos theory formulas while simultaneously instant messaging and posting on FaceBook what you ate... but in reality, what did you create?"
- DieHard, random forum troll at macos9lives.com

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 84
Re: sound diver troubles w MOTU?
« Reply #7 on: September 24, 2018, 11:36:20 PM »
well, a single unitor8 works just fine... im going to test what happens with a single MOTU. maybe it doesnt like my MOTU network?

[edit] works just fine with a single MOTU... wonder if its just not compatible with networked interfaces, or if it needs to be set up a specific way.

[edit 2] SOLVED!!! in my particular environment, the MTP connected to my OS9 mac was "unit #2" in the chain, set to ID 9-16. I changed this to 1-8 and the other unit to 9-16, and it stopped complaining and is now working properly. of course, i now need to go back to my OSX machine and change all the midi ports there, but at least OSX is a lot less picky about things.
« Last Edit: September 25, 2018, 01:39:48 AM by refinery »
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline IIO

  • Platinum Member
  • *****
  • Posts: 2036
  • new to the forums
Re: sound diver troubles w MOTU?
« Reply #8 on: September 25, 2018, 12:59:26 PM »
aha, nice to hear.
"It is true that the "pre-emptive multitasking" advantage present in OS X can be illustrated by downloading CD-ROM ISOs and rendering chaos theory formulas while simultaneously instant messaging and posting on FaceBook what you ate... but in reality, what did you create?"
- DieHard, random forum troll at macos9lives.com

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 84
Re: sound diver troubles w MOTU?
« Reply #9 on: September 27, 2018, 01:50:39 AM »
THE MYSTERY DEEPENS!

so, after going back to my OSX machine, all kinds of stuff didnt work anymore. i wasnt getting midi data from almost anything, my midi monitor app showed nothing coming in from the motus... I was stumped for a couple days. but then i remembered something i saw offhand in Clockworks OS9 that had me thinking...
so i opened up the two side by side, OS9 and OSX versions... and they're different!!
the OSX version has absolutely no provision for setting up routing to and from the second computer. it appears that by default, almost nothing is being routed to the second computer. In Clockworks OS9, I went in and manually drew out all the device connections (as shown in red in the third picture) for both to and from devices.

This fully solved the problem, finally. both OSX and OS9 machines attached to either end of the MOTU network are now working 100% without issue. the only head-scratcher remaining is how *some* devices had existing routing from the second mac port, but not all of them. i didnt do that myself, at least, not intentionally.

it seems pretty wild that MOTU would have completely removed the ability to edit routing to/from the second computer. and its not a matter of it not seeing it, if you look in below the transport bar it shows the firmware for both units, the second one being noted by "NET" in front.


G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind