Author Topic: OS 9.2.2 Display Issues On Graphite Dual G4  (Read 1264 times)

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
OS 9.2.2 Display Issues On Graphite Dual G4
« on: June 25, 2018, 02:05:00 PM »
So i've been trying to get OS 9 up and running on my G4 for about 3 days now but ive hit a roadblock. when i boot OS 9 everything is perfect, screen resolution is good, colors are good and boarders are good but once i get past the "Starting Mac OS" screen and it loads the desktop wallpaper the monitor "No Signals" immediately. i know the system works because i can press the power button and have it make a noise, OS X 10.4 works flawlessly.



PowerMac G4 Dual 450 Mhz "Gigibit Ethernet"
Normal ATi Rage 128 Pro GPU with ADC
1.38 GBs of RAM
120 GB Boot Drive
Lenovo ThinkVision Monitor
Apple "Pro" Mouse & Keyboard
Mac OS 9.2.2 DragInInstall
bought my first mac in 2016, never bought a PC since

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #1 on: June 25, 2018, 02:51:37 PM »
So i've been trying to get OS 9 up and running on my G4 for about 3 days now but ive hit a roadblock. when i boot OS 9 everything is perfect, screen resolution is good, colors are good and boarders are good but once i get past the "Starting Mac OS" screen and it loads the desktop wallpaper the monitor "No Signals" immediately. i know the system works because i can press the power button and have it make a noise, OS X 10.4 works flawlessly.



PowerMac G4 Dual 450 Mhz "Gigibit Ethernet"
Normal ATi Rage 128 Pro GPU with ADC
1.38 GBs of RAM
120 GB Boot Drive
Lenovo ThinkVision Monitor
Apple "Pro" Mouse & Keyboard
Mac OS 9.2.2 DragInInstall

so it does now work after booting with "Shift". i guess now its time to go extension hunting
bought my first mac in 2016, never bought a PC since

Offline Astroman

  • Consistant Contributor
  • ***
  • Posts: 147
  • new to the forums
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #2 on: June 25, 2018, 03:42:41 PM »
I have a similiar effect with an ATI card in my G3 and an Eizo 1920x1200 Monitor.
If connected via DVI (digital) it goes black after boot, though the resolution is listed in the monitor control panel. Using the an VGA port with a DVI adapter solves the problem.
You may power down the machine and reset parameter Ram so it starts with a lower default resolution.

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #3 on: June 25, 2018, 04:19:10 PM »
I have a similiar effect with an ATI card in my G3 and an Eizo 1920x1200 Monitor.
If connected via DVI (digital) it goes black after boot, though the resolution is listed in the monitor control panel. Using the an VGA port with a DVI adapter solves the problem.
You may power down the machine and reset parameter Ram so it starts with a lower default resolution.

The monitor im using doesn't have the required extra 4 pins to do that (picture 1) but in (picture 2) my G4 runs OS 9 perfectly when booted into safe-mode so, shouldn't it be an extension issue?
bought my first mac in 2016, never bought a PC since

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 79
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #4 on: June 25, 2018, 06:32:26 PM »
what kind of monitor is it? it might be asking the card for a refresh rate it cant support.
rage 128 pro should be able to support 1920x1200 but i have no idea at what refresh rates.

i also agree w Astroman i'd try the vga with an adapter, the vga was always more forgiving than DVI on those early cards.
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #5 on: June 25, 2018, 06:55:38 PM »
what kind of monitor is it? it might be asking the card for a refresh rate it cant support.
rage 128 pro should be able to support 1920x1200 but i have no idea at what refresh rates.

i also agree w Astroman i'd try the vga with an adapter, the vga was always more forgiving than DVI on those early cards.

Lenovo ThinkVision L197 Wide, ive also tried a 4:3 Dell Monitor
all of my testing was done with VGA, my ATi Rage 128 Pro is the factory original, only has VGA and ADC. i really hope i can get this working
bought my first mac in 2016, never bought a PC since

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 79
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #6 on: June 25, 2018, 06:57:55 PM »
what kind of monitor are you connecting it to?
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 79
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #7 on: June 25, 2018, 07:02:18 PM »
actually scratch that, i failed to fully read your original post and the statement that its working perfectly in OSX.

somebody earlier mentioned a PRAM reset, that might be worth trying, my guess is its a refresh rate setting where during boot its doing a default and when it goes to the desktop its changing to whatever its set to in the monitors control panel. probably putting out like 72hz when it wants 60hz or something.

G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline GaryN

  • Platinum Member
  • *****
  • Posts: 881
  • active member
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #8 on: June 25, 2018, 07:07:24 PM »
so it does now work after booting with "Shift". i guess now its time to go extension hunting
Start by disabling any ATI or Nvidia extensions/Control panels that are running. They don't speak Lenovo-ish.

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 79
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #9 on: June 25, 2018, 07:11:15 PM »
more useful info in this thread, starting from this post, describing the exact behavior you are encountering:

http://macos9lives.com/smforum/index.php/topic,1311.msg21076.html#msg21076
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #10 on: June 25, 2018, 07:24:43 PM »
actually scratch that, i failed to fully read your original post and the statement that its working perfectly in OSX.

somebody earlier mentioned a PRAM reset, that might be worth trying, my guess is its a refresh rate setting where during boot its doing a default and when it goes to the desktop its changing to whatever its set to in the monitors control panel. probably putting out like 72hz when it wants 60hz or something.

my second monitor, a "Dell E193FP (60Hz)" does the same thing, ive reset the PRAM twice now (once with each monitor) and using my Dell monitor's handy control panel OS X makes it go to 75Hz at 1280x1024 (yikes)

tomorrow i'll record the behavior and post it here
bought my first mac in 2016, never bought a PC since

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #11 on: June 25, 2018, 07:26:41 PM »
so it does now work after booting with "Shift". i guess now its time to go extension hunting
Start by disabling any ATI or Nvidia extensions/Control panels that are running. They don't speak Lenovo-ish.

since i went on an extension hunt ive so far disabled every last one without a change in behavior (other than boot speeds) same with control panels
bought my first mac in 2016, never bought a PC since

Offline reader50

  • Consistant Contributor
  • ***
  • Posts: 50
  • New Member
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #12 on: June 27, 2018, 06:23:26 PM »
I've noticed a glitch on Radeon cards under OS 9, when connected to widescreen monitors over a digital connection (ADC or DVI).

nVidia card: all is well in 9 and X.
ATi card (X): all is well
ATi card (9) using a VGA port: all good
ATi card (9) using a DVI/ADC port: black screen after drivers load, if a widescreen resolution is selected. Everything fine if a 4:3 rez is selected.

The above results were obtained on a G4 AGP with Radeon 7000 / Radeon 8500 / GF 4600. I have my original Rage 128 Pro still, but haven't used it for at least a decade.

The monitor im using doesn't have the required extra 4 pins to do that (picture 1) but in (picture 2) my G4 runs OS 9 perfectly when booted into safe-mode so, shouldn't it be an extension issue?
You're reading their advice backwards. They mean using the VGA port on your graphics card. Or plugging a VGA adapter into a DVI port on your graphics card. (This would not apply to an ADC port, as the analog pins are not present with ADC).

Then take a VGA cable from that port (or adapter) to the VGA-in port on your monitor. If your monitor doesn't have VGA-in, this won't work.

Note that a Rage 128 Pro has dual ports, but it is a single-monitor card. If you plug monitors into both ports, one will go blank anyway.

Get another video card if you can, like a PCI card. Using a monitor connected to the other card, you can test resolutions on the Rage 128 Pro.

If you are being bit by the ATi / OS9 / widescreen-over-digital issue, you can avoid it by using the control strip resolution module. It will only offer safe resolutions. The Monitors control panel offers the widescreen resolutions that cause a black screen.

Alternatively, just get a later AGP video card. The Rage 128 is a really old card, even under OS 9. Only 16 MB VRAM. Originally spec'd at 1280x1024 via the digital connection, and 1600x1200 for the VGA connection.

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 79
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #13 on: June 28, 2018, 04:30:06 PM »
I've noticed a glitch on Radeon cards under OS 9, when connected to widescreen monitors over a digital connection (ADC or DVI).

nVidia card: all is well in 9 and X.
ATi card (X): all is well
ATi card (9) using a VGA port: all good
ATi card (9) using a DVI/ADC port: black screen after drivers load, if a widescreen resolution is selected. Everything fine if a 4:3 rez is selected.

i wonder if that's dependent on the generation of card. I have a 9650 in my MDD and a PCI 9250 and both work fine over digital with widescreen 1920x1200.
the 9650 actually drives two 1920x1200 displays over digital. the 9250 does the same resolutions over VGA & DVI.
the 9650 doesnt have full acceleration as its not a recognized card, but its so fast anyway that it overcomes most issues. I dont do any 3D with it anyway.


but yes, im in agreement with Reader50, just get a new card, i got the 9250 I mentioned above for $30 off ebay just a couple weeks ago. works like a champ.
« Last Edit: June 28, 2018, 04:47:13 PM by refinery »
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind

Offline macStuff

  • Platinum Member
  • *****
  • Posts: 852
  • www.oldschooldaw.com
    • www.oldschooldaw.com
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #14 on: June 28, 2018, 07:13:15 PM »
the 8500 works much better
my 8500 is one of my favourite cards to use
2nd only to the ti-4600 i think

i have the rage 128 pro and it doesnt do widescreen on a digital lcd but it works via VGA just fine
its a strange card in that regard
but seriously.. jsut replace with a radeon 7500 or 8500 and be done with it
and on to the next thing
owc sells 7500s for like 10 bucks now
but if u want my best reccommendation its the 8500 for price + performance its the best for macos9
the ti4600 is the best performacne but will cost u prob 100$ so its not really worth it to most of us audio people
the driver support with the 8500 is the best its rock solid 100%
and it lets u sidestep all the 9200/9250 headaches of having to be tricky with extensions

on modern monitors the dvi connection is much clearer + sharper image

aka chrisNova777 aka superNova777 aka geforceG4 | >>> http://www.oldschooldaw.com

Offline reader50

  • Consistant Contributor
  • ***
  • Posts: 50
  • New Member
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #15 on: June 28, 2018, 09:03:25 PM »
I figure it's a glitch in the OS 9 ATi drivers, for earlier cards. The same cards work fine in X, using later drivers. Recall that widescreen monitors were uncommon in the OS 9 days, especially over digital.

Offline macStuff

  • Platinum Member
  • *****
  • Posts: 852
  • www.oldschooldaw.com
    • www.oldschooldaw.com
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #16 on: June 29, 2018, 12:05:16 AM »
the Rage 128 Pro was the default card with the sawtooth in early 2000
even tho it looks similar to later cards i that it has both dvi + vga; PLEASE dont expect too much from it
its not as advanced as it looks when it comes to resolutions that didnt exist at the time it was released..
1650x1080 + 1900x1200 these resolutions were not available at that point in time
this is something alot of people seem to forget

by not available i mean. to the general public at large.. in general most people did not use those resolutions
as most people had consumer grade monitors that were mostly 800x600 + 1024x768
i had a viewsonic CRT at that point in time that i was happy with..
the "flat screen" crt's then were just coming out then.. and if u saw a LCD flat panel you would be like wow!!!! the future!!!
insanely impressed because they just werent "out yet" en mass
https://en.wikipedia.org/wiki/Display_resolution
aka chrisNova777 aka superNova777 aka geforceG4 | >>> http://www.oldschooldaw.com

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #17 on: July 03, 2018, 07:47:05 PM »
I'm very sorry I forget to update everyone on what I was doing about it, I got it to work to an extent but not fully... Lemme explain. So I connected it to my 1920x1080 display and boom desktop, so I set the resolution to 1280x1024 and swapped the vga cable from my HD monitor to my 4:3 one (the one that I want to use) it also worked not big surprise, but once I was done having my celebatory coke I decided to reboot, same problem. I can get the display to work properly I just need to boot it connected to my main monitor and then swap cables, which is super inconvenient


the Rage 128 Pro was the default card with the sawtooth in early 2000
even tho it looks similar to later cards i that it has both dvi + vga; PLEASE dont expect too much from it

I know I can get "the GTX 1080 Ti" of agp cards for the price of a happy meal but I really want to use this computer in it's stock configuration (and it hurts to think about buying another AGP GPU because I have a whole box of them), but it seems that might be my only choice
bought my first mac in 2016, never bought a PC since

Offline FdB

  • Vault Members
  • Gold Member
  • ***
  • Posts: 408
  • And then...
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #18 on: July 04, 2018, 06:11:02 AM »
Which DVI cable were/are you using?
This Must Be The Place

Offline reader50

  • Consistant Contributor
  • ***
  • Posts: 50
  • New Member
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #19 on: July 04, 2018, 12:10:25 PM »
... and it hurts to think about buying another AGP GPU because I have a whole box of them

There's been considerable luck with flashing PC vid cards to Mac firmware. I posted a list of GPUs with full OS9 drivers* here, sorted by speed. Do you have any of these in your box of spares?

If you do, hit our Video Cards forum. The top two pinned threads cover flashing for nVidia and Radeon cards.

* a few more cards have OS9 drivers, like the Radeon 9700. But they lack OS9 3D drivers, which break games. Or force them to software-rendering mode.

Offline IIO

  • Platinum Member
  • *****
  • Posts: 2029
  • new to the forums
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #20 on: July 04, 2018, 12:10:32 PM »
but in (picture 2) my G4 runs OS 9 perfectly when booted into safe-mode so, shouldn't it be an extension issue?

yes, absolutely.

you said you use our drag install. my i ask what G4 model and what video card you got?
"It is true that the "pre-emptive multitasking" advantage present in OS X can be illustrated by downloading CD-ROM ISOs and rendering chaos theory formulas while simultaneously instant messaging and posting on FaceBook what you ate... but in reality, what did you create?"
- DieHard, random forum troll at macos9lives.com

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #21 on: July 04, 2018, 01:59:47 PM »
Which DVI cable were/are you using?

I'm not using DVI nor can I, my Rage 128 has only ADC and   VGA, nor can I use a VGA-DVI adapter because my monitors are all DVI-D and all my adapters are DVI-I
bought my first mac in 2016, never bought a PC since

Offline FdB

  • Vault Members
  • Gold Member
  • ***
  • Posts: 408
  • And then...
Re: OS 9.2.2 Display Issues
« Reply #22 on: July 06, 2018, 09:54:38 AM »
The reason that I asked about your DVI cable is that I have a similar card
running an LG 27" DVI-D monitor using an ADC to DVI adapter,
similar to the adapter pictured below.

(photo courtesy of MacOSPlus)
This Must Be The Place

Offline Snoop_Doggs_IT_Guy

  • Member
  • *
  • Posts: 9
  • that one guy who does stuff
Re: OS 9.2.2 Display Issues
« Reply #23 on: July 09, 2018, 02:01:20 PM »
The reason that I asked about your DVI cable is that I have a similar card
running an LG 27" DVI-D monitor using an ADC to DVI adapter,
similar to the adapter pictured below.

(photo courtesy of MacOSPlus)

yeah, i dont have one of those, where could i buy one?
bought my first mac in 2016, never bought a PC since

Offline reader50

  • Consistant Contributor
  • ***
  • Posts: 50
  • New Member
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #24 on: July 10, 2018, 01:25:06 PM »
They aren't made any more. You have to watch ebay for one to turn up. Search for "ADC DVI adapter" - unfortunately, you'll get results for the wrong adapter that goes the other way.

I had to watch for maybe a month before one of the right adapters appeared. Once it does, grab it fast. They sell quickly.

Offline refinery

  • Consistant Contributor
  • ***
  • Posts: 79
Re: OS 9.2.2 Display Issues On Graphite Dual G4
« Reply #25 on: July 12, 2018, 04:06:42 PM »
They aren't made any more. You have to watch ebay for one to turn up. Search for "ADC DVI adapter" - unfortunately, you'll get results for the wrong adapter that goes the other way.

I had to watch for maybe a month before one of the right adapters appeared. Once it does, grab it fast. They sell quickly.

accurate. i waited about six weeks to get one. guy in canada, $19 + 5 shipping, now im all good (and it even works with a dvi-HDMI adapter attached to it)
G4/MDD 1.42 (9), G4/GB 500DP (X), Beige G3 400 (9), PBG4Ti 1Ghz (X), PBG3WS 300 (9)

got my mind on my scsi and my scsi on my mind