Classic Mac OS Software (Discussions on Applications) > PowerPC OSX-based DAW Applications

Searching for Logic Pro 7.2

(1/4) > >>

Philgood:
Hi,

i have that Quad G5 here and would like to install my original Logic Pro 7 on it.  There was a paid upgrade from the 7.1 version i have to 7.2 to have full support for the 2xdual core processors.

Can anyone provide me that one ?

devils_advisor:
http://support.apple.com/downloads/DL326/en_US/LogicPro723.dmg


try that one

Philgood:
Thanks. I tried that and it complained about not having installed 7.2.

There is a 7.2.1 updater too on the apple site but it's the same. Shouldn't suprise anyone because effectively 7.2 was a paid upgrade (20$/€) during a short time.

I did some progress though and that was editing the version.plist file in the logic application. You know...right click over the application > show contents...and there you have a .plist file which is called version.plist.
I opened it with TextEdit and changed two lines where it says 7.1.1 as the installed version I have to 7.2 and that tricked the update installer 7.2.1. I did the 7.2.3 also right away but under my Leopard installation 10.5.8 logic gets stuck starting up during the "Loop browser initializing".
I found forum threads in internet saying that it could last as long as 12 minutes to get through that so I let it run while I left off but it still didn't load when I was back after a longer time.
It doesn't seem freezed or crashed at least looking at the Force quitting menu or the activity monitor so eventually I should just let it run longer or do an install without the apple loops just to rule things out.
I also did a suggestion I found saying to delete the index file for the loop browser but it didn't help either.

I got the idea of trying it with the tiger install I have on the same G5 quad and did the same procedure to install logic pro 7.2.3.
Now Logic when trying to start up is complaining about not having installed something called "Pro Application Support 3.1".
So I looked up for it and on the apple site I can only find the Pro Application Support 3.1 for panther (10.3) but I tried it anyway. The installer of it doesn't let me choose any OS partition I have showing the red exclamation for tiger (boot drive).

Philgood:
During further investigation I just tried with all relevant files I could find at the apple downloads. There are called Pro Application Support Update. I did try with the ones from 2005 (there are two from this year) through 2007 but the installers always said the update isn't needed.
When you Google for the one Logic is complaining about you will find sources saying there were two versions of the download.
Pro application support 3.1 for panther and another for tiger but on the apple downloads site there is only the panther one.
I will try the webarchive now...

Philgood:
Maybe it's still something missing from the 7.2 installer I didn't run. Remember I only tricked the 7.2.1 update installer to run after modifying the version.plist file of the installed 7.1.1 version I have so it's possible that the needed Pro Application Support file is covered by the 7.2 installer...guess I'm still looking for that one.
Anyone?

Navigation

[0] Message Index

[#] Next page

Go to full version