Author Topic: 23" Apple Cinema HD Display (ADC) not working  (Read 780 times)

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
23" Apple Cinema HD Display (ADC) not working
« on: May 26, 2017, 03:02:35 PM »
Hi folks,

Got a G4 AGP Graphics in which I recently upgraded the GPU. I put in an ATI Radeon 9000 64MB with DVI and ADC port. The ADC port doesn't work as the sawtooth doesn't provide the card with the right power, so I also got an Apple DVI to ADC adapter.

The display gets power (through the adapter) but no signal. Here's what I've tried so far and the results:

1. ATI Rage 128 Pro > DVI/ADC Adapter > Display
It works, I can see the boot screen but then the display goes black.
The Rage Pro doesn't have enough VRAM so figured it wouldn't work but just for test sake...

2. ATI radeon 9000 > DVI/ADC Adapter > Display
No signal, not even during boot.

3. ATI Radeon 5770 (Mac Pro) > DVI/ADC Adapter > Display
No signal, not even during boot.

4. ATI Radeon 5770 (Mac Pro) > Mini DisplayPort to DVI Adapter > DVI/ADC Adapter > Display
Display works beautifully.

Both OS 9 and OS X 10.4 on the G4 have all the latest ATI drivers. I can't figure this one out. Is it a single-link DVI VS dual-link DVI thing? is it a DVI-I (9000) VS DVI-D (Adapter) thing?

Halp :( Would really like to use this display. Currently typing this on the G4 with a 1080p DVI display attached and it works fine.

Offline devils_advisor

  • Platinum Member
  • *****
  • Posts: 652
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #1 on: May 26, 2017, 03:39:48 PM »
Try the non working machines again but trash the monitor prefs before. Besides i remember i had to reset my pram before booting the first time on one machine. It is possible your boot and main screen prefs are a problem.

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #2 on: May 26, 2017, 06:36:04 PM »
That had no effect.
The monitor doesn't even power on or anything when the Mac is booting on either OS 9 or X.

Since I had no video on the Mac Pro either when using the DVI port and had to use the Mini DisplayPort to DVI adapter for it to work, what could be the problem this adapter is having with DVI? DVI-I should be able to take a DVI-D cable/display no?

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #3 on: May 26, 2017, 08:22:53 PM »
Could it be a resolution problem?

There are a lot of resolutions available in both OS 9 and OS X but none of them are the weird resolutions MacTracker shows for this display:
800x500, 1024x600, 1280x800 and 1920x1200

Tried to stumble my way to a custom resolution with SwitchResX on OS X (using remote desktop and with the ADC display connected), only results in garbled screen. Also, OS X under System Profiler does not recognize a display being attached.

Offline Fury deBongo

  • Consistant Contributor
  • ***
  • Posts: 85
  • "It's ALIVE!"
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #4 on: May 26, 2017, 09:02:12 PM »
Perhaps a very stupid question, but why are you adapting back to ADC when the display accepts DVI? Seems like the reverse of what I was attempting before... coming out of the ADC port on my video card to convert to DVI and needing that ADC adapter. If you're not using the ADC out from your video card because it won't power the monitor, you expect power to come from the DVI connection on that card to your monitor? Don't those studio displays have a power adapter? If I'm missing something, just ignore me. DVI out, DVI in?
This Must Be The Place - Talking Heads

Offline Fury deBongo

  • Consistant Contributor
  • ***
  • Posts: 85
  • "It's ALIVE!"
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #5 on: May 26, 2017, 09:05:52 PM »
Forgot the attachment. ::)
This Must Be The Place - Talking Heads

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #6 on: May 26, 2017, 09:06:23 PM »
This is the plastic version, not the aluminum one. So ADC is all I got :)
Well I have DVI thanks to the adapter but isn't doing me much good it seems.

Offline Fury deBongo

  • Consistant Contributor
  • ***
  • Posts: 85
  • "It's ALIVE!"
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #7 on: May 26, 2017, 09:19:21 PM »
My humble apologies. Just checked on ADC version of that monitor... after I posted. Still, thinking that DVI converted to ADC is not providing all that you need for that monitor. Good luck. I'm going DVI out (hopefully soon), to a flat panel display. I avoided that change forever.  ;)
This Must Be The Place - Talking Heads

Offline devils_advisor

  • Platinum Member
  • *****
  • Posts: 652
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #8 on: May 27, 2017, 04:43:53 AM »
Can you show me a picture of that setup/connection? I know they sell a brick for that and i have used them to get it working.

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #9 on: May 27, 2017, 09:41:07 AM »
Let me know if this isn't what you were looking for.

ATI Radeon 9000 Pro -> DVI to ADC Adapter -> ADC 23" Cinema Display

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #10 on: May 27, 2017, 09:59:45 AM »
With the Mini DisplayPort to DVI Adapter, this display works on any Mac with a MiniDP port. Mac mini, iMacs, Mac Pro, MacBook Pro's etc.

Connected directly to a DVI port (on any Mac I've tried), I get nothing.

The MiniDP to DVI adapter (Apple part nr A1305) is Single-Link DVI-D. The DVI to ADC Adapter is Single-Link DVI-D. All the Macs I have access to use DVI-I (mix of Dual and Single Link).
« Last Edit: May 27, 2017, 11:55:21 AM by Dogcow »

Offline devils_advisor

  • Platinum Member
  • *****
  • Posts: 652
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #11 on: May 27, 2017, 12:03:38 PM »
Let me know if this isn't what you were looking for.

ATI Radeon 9000 Pro -> DVI to ADC Adapter -> ADC 23" Cinema Display


this adapter is for a dvi card to adc monitor.there is no reason why it should not work on a dvi port on any mac that has a dvi port. Need to inspect that further.

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #12 on: May 27, 2017, 12:07:30 PM »
Wish I knew how to/what to inspect. If it made even a little bit of sense I might have a starting point.

Offline devils_advisor

  • Platinum Member
  • *****
  • Posts: 652
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #13 on: May 27, 2017, 12:43:21 PM »
whenever i use that adapter i have to reset the pram to change the bootscreen and mainscreen settings to make sure that the monitor is used

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #14 on: May 27, 2017, 03:14:01 PM »
I'll give that another try.

Even though the Mac doesn't recognize the display, when I switch back to another screen the resolution is all out of whack, so it's doing something. I just can't see what it is ;) (on the G4)
« Last Edit: May 27, 2017, 05:35:56 PM by Dogcow »

Offline devils_advisor

  • Platinum Member
  • *****
  • Posts: 652
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #15 on: May 27, 2017, 03:44:50 PM »
If you can setup a dual screen machine with a known computer that doesn't accept the monitor.
Check the monitor panel and tell me what you see. In os9 you can have both monitor panels on the main screen.

Offline Dogcow

  • Member
  • *
  • Posts: 9
  • new to the forums
Re: 23" Apple Cinema HD Display (ADC) not working
« Reply #16 on: May 27, 2017, 05:30:16 PM »
I tried on a 2007 MacBook Pro with DVI port. When I connect the DVi/ADC adapter the laptop screen goes black for a second (typical behavior when connecting another screen) and then comes back normal. The external display is not recognized by the system at all.

I only have 1 OS 9 machine, the G4, and only have 1 GPU for it. The card I took out is also AGP so I can only run one.

When I connect the DVI/ADC adapter to the DVi port on the Mac Pro, nothing happens at all, not even the one second going black of the other screens. Display is not recognized by the system.

Also tried with PRAM resets on the G4, no dice.