Author Topic: Edirol UM-1 MIDI installer for MacOS 9 won't execute  (Read 987 times)

Offline ametts

  • Member
  • *
  • Posts: 8
  • new to the forums
Edirol UM-1 MIDI installer for MacOS 9 won't execute
« on: December 26, 2016, 05:45:24 PM »
Hi folks,

Roland posts a MacOS 9 driver for their UM-1 MIDI Interface here [1].  The download is posted as a .tgz file and not a Stuffit archive.

Stuffit (the default version in the MacOS9Lives image) expands the file, but the driver installers (the "Driver E" files) just show up as non-executable documents. Can anyone help me get past this?  Presumably there are three potential solutions:

--1-- Suggest a better location to download UM-1 MIDI drivers for MacOS9 -- perhaps as a Mac-friendly Stuffit archive.

--2-- Suggest a better way to extract the .tgz file within MacOS 9, so that the original executable status is preserved.

--3-- Suggest a way to make the non-executable documents actually execute (assuming the files aren't corrupted in some other way).

Thanks in advance,
Allan

[1] Roland UM-1 MIDI Drivers for MacOS 9
https://www.roland.com/global/support/by_product/um-1/updates_drivers/

Offline knightshaft

  • Member
  • *
  • Posts: 7
  • new to the forums
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #1 on: February 18, 2017, 02:21:19 PM »
Glad I'm not the only one with this problem and it still exists 18th February 2017

Offline devils_advisor

  • Platinum Member
  • *****
  • Posts: 653
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #2 on: February 18, 2017, 04:10:56 PM »
https://www.roland.com/global/support/by_product/um-1/updates_drivers/
it is the same archive. we would need the creator information and so on and just maybe you can make it useful again.
if you have a older version look at the creator infos and use them on this installer it might work.
the other 2 files are settings you might be able to import them with the apps and resave each one to get them back to normal.
try that
« Last Edit: February 19, 2017, 05:30:12 AM by devils_advisor »

Offline PaSiTee

  • Member
  • *
  • Posts: 3
  • new to the forums
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #3 on: April 13, 2017, 11:23:01 AM »
Any progress with this? I also downloaded the driver from Roland but it has the resource fork missing. Claims to be a simpletext document.

Offline Syntho

  • Platinum Member
  • *****
  • Posts: 904
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #4 on: October 07, 2017, 05:31:35 PM »
I'n having the same problem. I just bought two of these interfaces. I hope that doesn't mean even more $$$ down the drain.

Offline Syntho

  • Platinum Member
  • *****
  • Posts: 904
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #5 on: October 07, 2017, 05:37:51 PM »
The UM2EX driver for OS9 works fine, but it's not the same interface. Maybe that package will help with hacking the old UM-1 drivers?

Offline Syntho

  • Platinum Member
  • *****
  • Posts: 904
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #6 on: October 14, 2017, 10:14:36 PM »
Someone reading this has GOT to have the driver!

Offline macStuff

  • Consistant Contributor
  • ***
  • Posts: 101
  • New Member
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #7 on: October 15, 2017, 01:03:36 AM »
i just retrieved this file from the japanese support site
at the following URL:
https://www.roland.com/jp/support/updates_drivers/t_z/

should support the following different models of the um-1 family:
EDIROL UM-1
UM-1S
UM-1X
UM-1SX
UM-1EX

seems to contain both the oms + freemidi settings aswell
« Last Edit: October 15, 2017, 01:17:54 AM by macStuff »

Offline Syntho

  • Platinum Member
  • *****
  • Posts: 904
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #8 on: October 15, 2017, 03:29:06 AM »
FINALLY!

Offline macStuff

  • Consistant Contributor
  • ***
  • Posts: 101
  • New Member
Re: Edirol UM-1 MIDI installer for MacOS 9 won't execute
« Reply #9 on: October 20, 2017, 05:38:47 PM »
i have the original UM880 CD that came with my Edirol/Roland UM-880
when im able to find it i can upload a full iso of that - i believe it has the um-1 drivers on it aswell
the installer is marked as Driver-J or whatever so it may come up in japanese.. should try to find the Driver-E or Driver-F installers aswell (french + english)