Author Topic: Powerbook 1GHZ Titanium Power Issue  (Read 650 times)

Offline startech

  • Member
  • *
  • Posts: 7
  • new to the forums
Powerbook 1GHZ Titanium Power Issue
« on: October 11, 2016, 02:53:14 PM »

Hiya,

  Just picked up a Powerbook 1GHZ Titanium to run OS9 Natively. I also purchased a new battery for the laptop. I ran system profiler and the powerbook doesn’t seem to want to charge any battery that I place in the machine (tried 3 different batteries). It will run if it is plugged directly into the charger though. From a preliminary search online, would I have a DC Board issue?


Thank you!

Offline Philgood

  • Gold Member
  • *****
  • Posts: 260
Re: Powerbook 1GHZ Titanium Power Issue
« Reply #1 on: October 12, 2016, 06:56:57 AM »
i had problems with using non-apple chargers. is it still the original charger ?

maybe a dead pram battery can cause this ?

did you try to reset the energy managment ?

I know these are all more questions but maybe something you still didn't try.
*G4 MDD 1.25GHz (Single 2003)* with 2x 80Gb harddrives, 1Gb RAM, Tascam US-428 and Edirol FA-101 USB/Firewire soundcards-*iMac G3 DV 400MHz* with installs from OS 8.6-OSX Tiger on different harddrives-*Powerbook G4 1.67Ghz* with new SSD ! Love it.