Author Topic: Macintosh TV Question  (Read 5503 times)

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Macintosh TV Question
« on: June 24, 2016, 11:40:44 AM »
Not sure if anyone can help, but here goes.

I've got an old Macintosh TV  (http://www.everymac.com/systems/apple/mac_classic/specs/mac_tv.html in case your wondering)

It randomly chooses not to boot  (think flashy question mark).  I have pulled the drive, put it in an external enclosure and it works fine on other systems.
I have but other drives in the TV and they don't work either.
When this all happens I sit and remove the drive and stuff trying to figure it out.  Then I give up.  Come back a day later and the damn thing works.  My initial thought is that the cable going to the drive internally is loose or bad.  I believe this because through all the plugging and unplugging and moving it around that the cable moves and starts working again.

So the question is if anyone has any other ideas what could be going on with this before I take it apart to make sure all the internal cabling is working and connected well.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline GaryN

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1151
  • active member
  • Liked:
  • Likes Given: 0
Re: Macintosh TV Question
« Reply #1 on: June 24, 2016, 07:23:30 PM »
It really sounds like you may have already answered your own question. I was a bench repair tech in a past life. I lost count of the number of head-scratching bad behaviors I repaired by carefully resoldering perfectly fine-looking circuit boards. Wave soldering temps are always a compromise between too cold to flow properly and hot enough to damage the components. So, different-sized joints get soldered with varying degrees of effectiveness, hopefully all within an acceptable range. On connectors especially, where the connector pin is heavier than a typical component lead, that mass acts as a heat sink, preventing the solder from attaching perfectly. Sometimes you can see a microscopic crack with bright lighting and serious magnification, wiggling the pins one-by-one.

Check those connections and also look hard at any heat-generating component's connections. It's a repeated expansion and contraction of the solder joint causing a fine crack that you're looking for. The repeated warming / cooling from normal usage, gives you a joint that still looks perfect, but isn't. Instead, it now works as long as the two sides are touching "enough". Then, a little heat or vibration, and poof…

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #2 on: July 14, 2016, 09:37:18 AM »
Okay I had the whole thing apart (respect to all those people who had to service these machines back in the day as this just confirmed to me why I'm software and not hardware). And no luck finding anything.  I can get it to boot from the CD drive sort of.  The only cd I have is the original restore disc which is sadly very very scratched so it dies a glorious death on boot.  Some times it even gives me the black screen sad mac.
Can't get it to boot from an external drive yet either.  Oh sad day.
Still working on it though.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline GaryN

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1151
  • active member
  • Liked:
  • Likes Given: 0
Re: Macintosh TV Question
« Reply #3 on: July 14, 2016, 04:09:23 PM »
OK Nano… you're now officially in "hardware repair hell". Time to call the big guns.

DIEHARD ! Where do you go from here?

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #4 on: July 14, 2016, 04:47:57 PM »
On the plus side I got to discharge a CRT for the first time.
And having to take the entire machine apart to get at the cables for the drives is a bit of a pain.

So here's what I don't get (and maybe this is obvious to someone else). The CD-ROM and HD are on the same scsi cable.  There does not appear to be a terminator with in either device or on the cable.  Is it on the main board somehow?  I'm starting to wonder if it's not the drive though. I know it worked in an enclosure, but I only tried it to verify it and put it back and it worked. I haven't tried it again now that it is not working.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline Mat

  • Gold Member (200+ Posts)
  • *****
  • Posts: 464
  • Liked:
  • Likes Given: 0
Re: Macintosh TV Question
« Reply #5 on: July 14, 2016, 05:04:38 PM »
Working - not working - working - not working usually hints to any dead    electrolytic capacitors. So if you can exclude a strange SCSI issue, you should check all of them, and see if they are dead. I could rescue 2 PCs yet by replacing them for a few bucks. But I don´t know if the TV got already SMD ones, which are much harder to replace. My 9600 got them and I still didn´t start to do it, but I am quite sure its them.
Had similar behavior, one day it worked, the other it refused to boot.

On the other hand, that you can boot - somehow - from the CD, but not from the drive anymore sounds like some SCSI problem and/or a dead HD.

Offline DieHard

  • Administrator
  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1750
  • Liked:
  • Likes Given: 11
Re: Macintosh TV Question
« Reply #6 on: July 14, 2016, 05:16:26 PM »
Quote
On the plus side I got to discharge a CRT for the first time.
And having to take the entire machine apart to get at the cables for the drives is a bit of a pain.

LMAO, yeah, I got a few really bad shocks in the day from those internal Apple CRT, So that really is an accompaniment. A Long Screw driver and rubber gloves helps :)

Ok a few things,
1) Examine the Internal battery area for leakage and ruined areas from acid spillage (very common)
2) Examine all Capacitors, you probably did that, but I will say it again as it is the #1 issue, Swollen or leaking tops

Here is the Entire Repair Manual

As far as the SCSI, look on the bottom of the HD for long red connectors that have pins that go into holes in the HD board, these were "old style" SCSI terminators on the Device itself.

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #7 on: July 14, 2016, 05:25:25 PM »
Thanks for the input I'll check all these.

Not that it's the most useful machine, but it's the first computer my family had and it's kind of a nostalgia thing for me to still be using it.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #8 on: October 10, 2017, 12:09:37 PM »
Oh the joy of bringing an old dead thread back from the grave. I guess it's fitting.

I'm hell bent on making this work within reason.
So I hadn't done a thing to this machine since my last post in the thread.
Got a day home from work yesterday with a sick kid so I decided to work on this and a Performa 450 I just got.  The Performa worked for about 10 minutes, then the drive died. Go figure, no surprise. Not important though.

So I pulled the TV out and checked the drive again, via the Performa.  That's dead so move on.
Left the drive out, power on the TV.  Rather than the Mac showing the sad Mac face, it was me with the sad face.
I could hear the machine power on (typical power supply turning on and the wonderful sound of a CRT turning on).  I got super excited as it should show the image for not being able to find the startup folder/disk, and I should get the startup chime.  And none of this joy.

Next I turned it off and checked the logic board to make sure it is making contact.   
Power back on and now I have an even sadder face.  I don't even get the sounds from the first power up.


So I checked the battery and put a new one in even after cleaning the area. It didn't look like there was any crust or gross in the area, but hey clean anyway. 
I still have to check over all the caps.


Also can anyone recommend a place I might find a scsi drive for the performa (or the TV in the event I get it working) that does not have insane prices?
If it ain't broke, don't fix it, or break it so you can fix it!

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #9 on: September 18, 2019, 05:15:35 PM »
OH HEY!

Need some help on this.

So I plugged in the Macintosh TV (finally got back around to this).
Flip the switch,  no chime, no crt noise.  Nothing except the sad sound of a pop, small puff of smoke and a very bad smell.

I'm checking all the caps visually and not seeing that any had blown.
While it's apart is there any thing else I should check that could have made a pop and smoke?
If it ain't broke, don't fix it, or break it so you can fix it!

Offline GaryN

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1151
  • active member
  • Liked:
  • Likes Given: 0
Re: Macintosh TV Question
« Reply #10 on: September 18, 2019, 10:50:20 PM »
So the dead TV rises again years later but it's even deader than before?

If nothing lit up and you let the smoke out of something the moment you turned it on, start at the AC entrance and look for something exploded or burnt in the power supply area. Maybe a cap, maybe a current limiting resistor, maybe a MOV (looks like a little disc - at least it did before- it might not now).

If not there, the next likely place is the HV section that is the life of the CRT. At power-on, that's where the largest current draw is as the horizontal oscillator winds up and the tube charges etc. making that "CRT noise". Look near the flyback transformer where the CRT HV lead comes from and the oscillator transistor lives.

2 points:
1) Pop/smoke/smell almost always leaves evidence of where it came from.
2) Anything issues deeper than this are NOT something you generally fix with advice over the internet…

**************
FUNNY!

After posting the above I happened across this (pic below) on FartBook. This guy at least, discovered he had installed a cap backwards…
« Last Edit: September 18, 2019, 11:12:00 PM by GaryN »

Offline FdB

  • Moderator
  • Platinum Member (500+ Posts)
  • *****
  • Posts: 666
  • And then...
  • Liked:
  • Likes Given: 0
Re: Macintosh TV Question
« Reply #11 on: September 18, 2019, 11:12:02 PM »
Is Gary "on fire" or what lately? 8)
2 points:
1) Pop/smoke/smell almost always leaves evidence of where it came from.
2) Anything issues deeper than this are NOT something you generally fix with advice over the internet…

Hey Nano, might have a SCSI drive for ya... if you resurrect that thing. ;)
This Must Be The Place

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #12 on: September 19, 2019, 06:03:04 AM »
So the dead TV rises again years later but it's even deader than before?

If nothing lit up and you let the smoke out of something the moment you turned it on, start at the AC entrance and look for something exploded or burnt in the power supply area. Maybe a cap, maybe a current limiting resistor, maybe a MOV (looks like a little disc - at least it did before- it might not now).

If not there, the next likely place is the HV section that is the life of the CRT. At power-on, that's where the largest current draw is as the horizontal oscillator winds up and the tube charges etc. making that "CRT noise". Look near the flyback transformer where the CRT HV lead comes from and the oscillator transistor lives.

2 points:
1) Pop/smoke/smell almost always leaves evidence of where it came from.
2) Anything issues deeper than this are NOT something you generally fix with advice over the internet…

**************
FUNNY!

After posting the above I happened across this (pic below) on FartBook. This guy at least, discovered he had installed a cap backwards…


Thanks Gary  I'm not one to usually follow internet advise for when it get's deeper, I just know some of the people here have dealt with analog board issues so wanted to get an idea for any common pit falls with them.

I did find a blown cap in the HV section.  So this thing may live again.

Is Gary "on fire" or what lately? 8)
2 points:
1) Pop/smoke/smell almost always leaves evidence of where it came from.
2) Anything issues deeper than this are NOT something you generally fix with advice over the internet…

Hey Nano, might have a SCSI drive for ya... if you resurrect that thing. ;)

Thanks,  I'll keep you posted if it comes back to life.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline GaryN

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1151
  • active member
  • Liked:
  • Likes Given: 0
Re: Macintosh TV Question
« Reply #13 on: September 19, 2019, 05:21:53 PM »
I did find a blown cap in the HV section.  So this thing may live again.
You should know and remember the seemingly main pastime of vintage (especially pre-PPC) Mac owners / collectors is re-capping the whole damn system. The propensity of certain types of old caps (especially electrolytics) to dry out, leak, split open, smoke, throw up and otherwise defecate on the motherboards of old Macs is SO common and notorious that complete replacement of ALL of them has become a "first thing you do" when buying an older Mac.

In your case it's undoubtedly worth it. The Mac TV is a bona fide collector's item.

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #14 on: September 20, 2019, 06:49:53 AM »
I did find a blown cap in the HV section.  So this thing may live again.
You should know and remember the seemingly main pastime of vintage (especially pre-PPC) Mac owners / collectors is re-capping the whole damn system. The propensity of certain types of old caps (especially electrolytics) to dry out, leak, split open, smoke, throw up and otherwise defecate on the motherboards of old Macs is SO common and notorious that complete replacement of ALL of them has become a "first thing you do" when buying an older Mac.

In your case it's undoubtedly worth it. The Mac TV is a bona fide collector's item.

A recap has is on the project list for this thing (amongst other things). 
If it ain't broke, don't fix it, or break it so you can fix it!

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #15 on: March 10, 2020, 07:56:03 PM »
And yet again I bring an old thread back from the grave.  I'm kind of enjoying that a bit.
Good news!  It powers on!  Did a little recapping on the analog board and boom, it powers on.
I can boot off floppy so that is good.  Drive still not recognized.  Tried two separate drives though I don't know if either one works.
But, I am now able to at least power it on to continue trouble shooting!  Now just to recall where I put the restore disc and CD caddy.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline GaryN

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 1151
  • active member
  • Liked:
  • Likes Given: 0
Re: Macintosh TV Question
« Reply #16 on: March 10, 2020, 11:00:58 PM »
But, I am now able to at least power it on to continue trouble shooting!  Now just to recall where I put the restore disc and CD caddy.
Congrats! You've graduated to electronic repair 201 !
This is where you have successfully fixed the first problem that was preventing you from troubleshooting the second problem!
This is probably where you start looking for a proper replacement restore disc.

The saga continues……

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #17 on: March 11, 2020, 06:16:52 AM »
But, I am now able to at least power it on to continue trouble shooting!  Now just to recall where I put the restore disc and CD caddy.
Congrats! You've graduated to electronic repair 201 !
This is where you have successfully fixed the first problem that was preventing you from troubleshooting the second problem!
This is probably where you start looking for a proper replacement restore disc.

The saga continues……
Well I would say it was more like I fixed the second problem that popped up while trouble shooting the first problem which was originally the HD not being found, but in the end it's still in better shape now.

I think I've been past the electronics repair 201 for some time, I just don't like to admit it.

I'll work on it more tonight and hopefully figure out what went wrong.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #18 on: March 11, 2020, 07:23:55 PM »
Quick update.
I located my restore CD and CD Caddy!  CD drive still works.  Tried a working disk drive in it an that isn't recognized.
Didn't have time to tear it down to check the internal cabling.  The external SCSI port seems to be non-functional at all, but I think a parallel port zip drive accidently got plugged into it some years ago and damaged that.

Did the scsi controller in these have any sort of drive size limit like the IDE controllers did in the G3 line?
If it ain't broke, don't fix it, or break it so you can fix it!

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #19 on: March 22, 2020, 12:27:08 PM »
Well All things what they are, I am now stuck.
I do not have a functional SCSI drive that I can test with.  The two I have are both bad.
So on the hunt for a new drive.

And just to add insult to injury, while pulling the analog board back out to check connections for the drives and such, I had a slip of the finger and pulled a cap out right off it's leads.   Oh well got a new one on order.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline FBz

  • Veteran Member (100+ Posts)
  • ****
  • Posts: 122
  • Older Than Dirt
  • Liked:
  • Likes Given: 29
Re: Macintosh TV Question
« Reply #20 on: March 22, 2020, 02:35:09 PM »
Hey Nano… is there a size restriction on just how much HD that Mac will recognize or address? Dropped Caleb (part12studios) a note about your need as he recently acquired many SCSI drives from his visit to the Mac Museum and if he can’t provide you with a drive, I may have one suitable for your use. Post your req's here and we'll work forward from that. Cheers!

Offline ssp3

  • Enthusiast Member (25+ Posts)
  • ***
  • Posts: 63
  • Liked:
  • Likes Given: 0
Re: Macintosh TV Question
« Reply #21 on: March 22, 2020, 03:24:54 PM »
IIRC, on non PowerPC Macs anything larger than 2GB as boot drive will not be recognized. The trick with 2GB partition on a larger drive will not work. Formatting non Apple drives might be an issue as well.

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #22 on: March 23, 2020, 07:00:19 AM »
Hey Nano… is there a size restriction on just how much HD that Mac will recognize or address? Dropped Caleb (part12studios) a note about your need as he recently acquired many SCSI drives from his visit to the Mac Museum and if he can’t provide you with a drive, I may have one suitable for your use. Post your req's here and we'll work forward from that. Cheers!

Greatly appreciated.
The system had a 160 MB drive in it and I'd like to keep it roughly in that range just out of the desire to keep it as original as possible. No more than 2gb though due to this comment 
IIRC, on non PowerPC Macs anything larger than 2GB as boot drive will not be recognized. The trick with 2GB partition on a larger drive will not work. Formatting non Apple drives might be an issue as well.
Don't want to tempt fate with that.
If it ain't broke, don't fix it, or break it so you can fix it!

Offline FBz

  • Veteran Member (100+ Posts)
  • ****
  • Posts: 122
  • Older Than Dirt
  • Liked:
  • Likes Given: 29
Re: Macintosh TV Question
« Reply #23 on: March 23, 2020, 05:32:48 PM »
Collected some likely candidates today and after the SyQuest / SCSI exercise,
I've now a direct "shunt" to easily test them all - possibly as early as tomorrow.

Offline nanopico

  • Platinum Member (500+ Posts)
  • *****
  • Posts: 735
  • Liked:
  • Likes Given: 3
Re: Macintosh TV Question
« Reply #24 on: May 07, 2020, 08:35:53 PM »
Thank you everyone who helped with this.
The good news, is that the Macintosh TV is now restored back to it's sort of original functionality.
The original problem was the hard drive died. 
And in trouble shooting that a capacitor blew.
And in fixing that I accidentally ripped a capacitor off the analog board.
With a few new caps and a different drive, use of a third party tool to initialize and format the drive,
And boom.  It's back to functioning.
If it ain't broke, don't fix it, or break it so you can fix it!