Classic Mac OS Software (Discussions on Applications) > Photo/Image/Graphics Viewing & Editing

Simple PDF Solution; "Gostscript" -> Developer Needed

<< < (2/14) > >>

nanopico:
Sorry I haven't gotten to look into this yet.  I've been involved in a nightmare of a project at work that pretty much sucks the life out of me the past month.

mrhappy:
I HATE those 'life sucking' projects!!! ;D ;D

nanopico:

--- Quote from: mrhappy on January 25, 2016, 06:45:19 AM ---I HATE those 'life sucking' projects!!! ;D ;D

--- End quote ---
Unfortunately they pay the bills.
I just wish customers wouldn't ask me to create an app, only tell me a tenth of what it needs to do and then wait until deployment to tell me another tenth of what is missing and so on and so on. Make's it hard to ever get the thing finished.
Never mind it's dealing with State regulations that seem to change every 3 months.

nanopico:
So if the exported functions and api's have not changed between 8.0 and the gpl 9.10  then  it would be possible to take the code that is platform agnostic code and put it into the 8.0, update some references and code to make it work.  So it should be possible to get the 8.53 working and possible create a 9.10 version. But please don't hold me to it. I haven't looked at the code yet.

nanopico:

--- Quote from: Mat on December 09, 2015, 11:50:52 AM ---This viewer needs the "MacGS shhlib" to compute the PDFs.
You can get those up to date GhostScript libs at the sourceforge site:

http://sourceforge.net/projects/ghostscript/files/

There is the former AFPL Ghostscript and the recent GPL Ghostscript. AFPL Ghostscript always had binaries (and sources) for Mac OS 9. The latest version of this "MacGS shhlib" (which is needed so that the above "MacGSView 2.0b3" can display PDFs) from AFPL Ghostscript is the version 8.51 from the year 2005.
http://sourceforge.net/projects/ghostscript/files/AFPL%20Ghostscript/8.51/
Sadly there is some problem and it doesnt work correctly.

Tha latest version I could use successfully is the 8.00 from 2002
http://sourceforge.net/projects/ghostscript/files/AFPL%20Ghostscript/8.00/


--- End quote ---

Did you happen to download any of this?  The downloads from source forge for these all are non-existent.  They all error as not found.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version