Classic Mac OS Software (Discussions on Applications) > Photo/Image/Graphics Viewing & Editing

Simple PDF Solution; "Gostscript" -> Developer Needed

(1/14) > >>

Mat:
As we are having some developers onboard now, I like to put a request here. It may be a easy solution, just needing a weekend for an experianced developers to make our Mac OS 9 computers a lot more usable for everyday tasks.

Please could somebody with codewarrior knowledge have a look!

One of the real problems we are facing is that Acrobat Reader 5.05 has come to age and is not able to render/display all modern PDF documents. Especially when it comes to  1.7 or 2.0 versions, or some 1.5 versions with unprintable content.

As there was always a Mac Ghostscript outside, it may be that it is totally simple for a developer, to push us to the present again and enable us to view all PDF documents. At least a huge improvement over Acrobat Reader should be easily possible. So here is the whole story:

There is MacGSView a viewer for PDF and PS files, distributed under the "Aladdin Free Public License". It is working well and additionally has a nice interface.

You can grab it here (plus the sources):
http://ftp.ntua.gr/mirror/ghost/aladdin/gs601/mac/test/

This viewer needs the "MacGS shhlib" to compute the PDFs.
You can get those up to date GhostScript libs at the sourceforge site:

http://sourceforge.net/projects/ghostscript/files/

There is the former AFPL Ghostscript and the recent GPL Ghostscript. AFPL Ghostscript always had binaries (and sources) for Mac OS 9. The latest version of this "MacGS shhlib" (which is needed so that the above "MacGSView 2.0b3" can display PDFs) from AFPL Ghostscript is the version 8.51 from the year 2005.
http://sourceforge.net/projects/ghostscript/files/AFPL%20Ghostscript/8.51/
Sadly there is some problem and it doesnt work correctly.

Tha latest version I could use successfully is the 8.00 from 2002
http://sourceforge.net/projects/ghostscript/files/AFPL%20Ghostscript/8.00/

Sadly this is no real improvement over Acrobat reader.

I am quite sure that some codewarrior wizard could recompile the 8.51 from 2005 and bring us a huge step foreward immediatly. Perhaps it is even possible that the recent GPL Ghostscript is usable with the MacGS view easily? I cannot tell if huge porting would be needed or if it is as well a simple recompilation?

Can some developer please investigate and help !?



nanopico:

--- Quote from: Mat on December 09, 2015, 11:50:52 AM ---There is the former AFPL Ghostscript and the recent GPL Ghostscript. AFPL Ghostscript always had binaries (and sources) for Mac OS 9. The latest version of this "MacGS shhlib" (which is needed so that the above "MacGSView 2.0b3" can display PDFs) from AFPL Ghostscript is the version 8.51 from the year 2005.
http://sourceforge.net/projects/ghostscript/files/AFPL%20Ghostscript/8.51/
Sadly there is some problem and it doesnt work correctly.

--- End quote ---

If there are issues and problems in 8.51 recompilation will not fix those.  They would need to be fixed or you would still be in the same spot.  Someone with a good knowledge of the source base of Ghostscript (regardless of platform) could probably patch it quicker than anyone else.  So I'm not sure it would be a trivial task or not.  I might have some time next week or after the 1st of the new year to take a look at it though.

Mat:

--- Quote from: nanopico on December 09, 2015, 12:25:39 PM --- If there are issues and problems in 8.51 recompilation will not fix those.
--- End quote ---
The issue is 8.51 is simply not found by MacGSView. To me it looks the binary is damaged. Thatīs why I am speculating that a recompilation might solve the problem.


--- Quote from: nanopico on December 09, 2015, 12:25:39 PM --- So I'm not sure it would be a trivial task or not.
--- End quote ---
But you are somebody who could find it out ;)
I have no idea, perhaps it is complicated and needs heavy rework, but perhaps it is a trivial task. I am sure you can quickly get an overview and tell us more.


--- Quote from: nanopico on December 09, 2015, 12:25:39 PM --- I might have some time next week or after the 1st of the new year to take a look at it though.
--- End quote ---
That woudl be absolutely great!

Mat:
To specify the problems: MacGSView needs that "GhostScriptLib PPC" from AFPL GhostScrip inside the System Extensions. As said the version 8.00 is working well. The version 8.51 contains as well a carbonized lib. Both are "not found" as soon as you try to open any file with MacGSView.
Additionally the lib package macgs-851-shlib contains a very simple GS viewer called "gsclient" this one is crashing the entire Mac immediatly if used instead of MacGSView.

Mat:
Wanted to push this thread again, so perhaps nanopico or somebody else could have a look.

Navigation

[0] Message Index

[#] Next page

Go to full version