Classic Mac Hardware (Troubleshooting, Upgrading, & Modifying) > Storage Technologies

"Invalid Btree Header, 0, 0" error...

(1/12) > >>

Last night the harddrives of my MDD halted and after forcing the reboot i got the blinking Question mark Folder. Duh.
Harddrives dead i thought and so i got the idea to try to connect them to my windows box with an USB-IDE bridge adapter as i recently installed the demo version of Paragons HFS+ for windows. But it already passed the trial period so i had the stupid idea of buying their 2in1 bundle for 29$ only to see that it isn't working with OS9 least it's not working for me. i tried on the windows 7 partition first installing their program and after that on my XP partition. I searched the support forum but couldn't find any information about mac os9 partitions...Does anyone use their Program successfully ?
I'll request a refund as soon as possible if it's not working...

Well, i grabbed finally my Mavericks Macbook and connected them with the same USB-IDE adapter and got immediately all partitions shown on the desktop....should have tried that in the first place.
I made backups of the 2 harddrives with Superduper to an external Firewire one and did nothing else as to put the 2 harddrives back into the MDD as they didn't seem to be dead.
I only changed the configuration as before the 2 ones were connected to the same ATA100 bus as master/slave configuration so i put the system on the ATA66 and left the other one on the ATA100 bus.
My MDD booted and everything looks good but i'm getting now the famous "Invalid Btree Header, 0, 0" scanning with FirstAidUtility...sure this bad did the evil MacOSX but do i have to worry about it?
Is there any way to repair it ?

Thanks guys

i had the same problem and couldnt repair it.. once it happens the best thing u can do is back up all your data to a new drive .. and reinstall or restore using ASR.. ASR is a lifesaver for this kind of crap... but of course requires that u prepared a backup/restore image beforehand

i havent read of anyone finding a solution to this stupid error.
i have a feeling its caused by a clash between softwares' copyright techniques?
some people think its caused by using osx on the same partition as 9? i think its possible it can be caused by both.

I did some search on the forum so i`ll auto-respond me in the meanwhile  ;D

Look what DieHard posted regarding the issue...

--- Quote from: DieHard on September 01, 2013, 12:00:54 AM ---Don't know if this helps, but to avoid the whole

Invalid BTree Header , 0, 0

error; the basic rule of thumb is to not access any OS 8 or OS 9 volumes while being booted to OS X, eventually OS X will write to areas of the OS 9 volume that OS 8/9 will report as Invalid Btree Header 0,0; a real pain the the ass that no utilities (and I have tried them all) will fix... So, that is why I mentioned to keep OS 9 machines as OS 9 only and OS X Machines the same.`
--- End quote ---

The bold letters were put by me...Seems that i'm out of luck to try to successfully repair it.

--- Quote ---Use good old file sharing or FTP to transfer files or USE a home made firewire Flash drive... I made many FW400 flash drives with a Lexar FireWire CF Compact Flash Card Reader and a CF 4G or 8GB Card, this will transfer files between OS X and OS 9 with no issues.
--- End quote ---

I think i'll redone that Backups to make them straight from a OS9 CD booted...will try that Mactron goodie from here...

--- Quote ---PS: Get enough RAM in the unit to make a large RAM disk and Copy a stripped down 9.2.2 to it and reboot to it... your ACG400 will turn into a freakishly fast super Mac.

I and many others have done this.... from the Web...

"you first start up of the hard drive, make your ram disk say 130Mb(given the fact I have 160Mb), this leaves about 30Mb for applications and the OS.
restart the machine, the ram disk is now active. gut the dup the system folder and then gut it until is fits onto the 130Mb ram disk. Bless the system folder on the ram disk. choose the startup disk in via the control panel, restart. Power is stillgoing to ram so the contents of the ram disk are not boot of a ram disk, watch laptop battery life jump and a system that starts up in seconds  .
there you go people....booting off a ram disk 
that also why solid state ram drives have then own power instead of just of the PCI bus....."

--- End quote ---

I'm quite sure that having a ram disk isn't something recommendable in an audio production environment but maybe worth a try... 

yep the best way to avoid it is to not let osx "see" the os9 partition.. and vice versa..
for me this means if i want to use a g3 or g4 for os9 + osx .. always partition the drive.. and NEVER READ OR WRITE THE OTHER PARTITION!!! there are steps u can do to "hide" the drive so it doesnt show up.. on os9 this is accomplished in drivesetup i think? but u need a certain level version of drivesetup i think... and in osx.. i forget.. id have to google it..  so u would copy files to an external drive.. or copy them to a network share.. then reboot  to the alternate os and copy the files

ramdisk works too but is more applicable to small files

I just saw that speedy Chris posted before i could finish my post... ;)

Well, i think it's nothing critical to just wipe the system disk and make a fresh OS install. About the other one which contains Protools sessions with all the audio recordings i would prefer to salvage/preserve it...will this Btree header error affect the data sooner or later ?
What if all utilities seems to fail on this would be a good method of preserving the data ?
Just copy the data to another harddrive ? Will this restructure the directory problems ?


[0] Message Index

[#] Next page

Go to full version