Author Topic: early versions of NI Komplete?  (Read 2622 times)

supernova777

  • Guest
early versions of NI Komplete?
« on: May 30, 2015, 09:05:01 PM »
does anyone have these?

v1 released ??? 2003
v2 released june 2004
v3 released october 2005

i think 4 was the first version to drop support for mac os 9
but it could have been 3?

the oldest i have is:
v4 released october 2006
(which is 8 DVDs.. at least 6 of which are Dual Layer 8GB DVD)

i also have:
v5 released october 2007

the rest of the timeline is as follows (i believe)
please correct me if im wrong

komplete 6 in 2009,
komplete 7 in 2010,
komplete 8 in 2011,
komplete 9 in 2013

also if anyone has any info to share about any of the modern versions.. feel free to contribute that info aswell!
« Last Edit: May 31, 2015, 12:19:32 AM by chrisNova777 »

supernova777

  • Guest
Re: early versions of NI Komplete?
« Reply #1 on: May 30, 2015, 11:35:36 PM »

found these pics of the first collection from 2003!!
box matches the old native instruments website (that design was so cool!)

anyone know if this package also included RTAS versions?
i have a feeling that RTAS wasnt added untill possibly v3 or v4?
« Last Edit: May 31, 2015, 12:15:57 AM by chrisNova777 »

supernova777

  • Guest
Re: early versions of NI Komplete?
« Reply #2 on: July 16, 2015, 04:52:55 AM »
http://blog.ultimateoutsider.com/2014/09/the-complete-history-of-komplete-all.html

found this just now by accident;)

im still trying to figure out which box set of komplete was the last to include mac os 9 versions
i think it was 2.. but it might have been 3?

i was using v3 just yesterday but the installer i have is only for windows XP! lol (xp rules because u can find anything for it! cracked!)
anyway.. like i said in earlier posts..
i have v3,v4,v5 of komplete. thats it..
still trying to find someone who has version 2.0 or 1.0 on disc!
i tried to buy it on ebay but no luck so far


this is the last one to have mac os 9 versions i think.. unless someone has the k3 red box saying otherwise

this spreadsheet from the above link puts alot of info re: plugins in the package
in the later versions that i had no clue about:
https://docs.google.com/spreadsheets/d/1C2lEubeNV6OzUnj5o8o6pBPU_jGgzeCALNTLOnoPxeA/edit#gid=0

Offline DieHard

  • Administrator
  • Platinum Member
  • *****
  • Posts: 1257
Re: early versions of NI Komplete?
« Reply #3 on: July 16, 2015, 06:18:43 PM »
If anyone gets a bum DVD and cannot get a replacement; I have the original factory box sets of...

Komplete 5 Ultimate
Komplete 6 Ultimate
Komplete 7 Ultimate
and the HD for Komplete 8

supernova777

  • Guest
Re: early versions of NI Komplete?
« Reply #4 on: July 16, 2015, 07:54:10 PM »

how much do i have to pay ya to make me copes of 6 + 7 ? ;)
i should just go buy the new version.. whats it at now. 10? maybe even 11

what do u mean "the hd" for 8?
it came with its own HD??
oh shit.. there it is .. in the pic even!!
wow i never knew that
looks like a laptop size sata drive? or is it usb only?

its too bad we cant find mac versions of 2 + 3
remember i said 2 was from 2004, and 3 is from 2005

2 for sure has mac os 9 versions...
3 might be osx only.. but theres a chance it may havd os9 versions aswell..
id really like to get this fact confirmed.. if anyone knows + can confirm with a pic of the rear box of komplete 3
or manuals or something..

heres a musiciansfriend page for 3:
http://www.musiciansfriend.com/software-synths-samplers-software/native-instruments-komplete-3

FEATURES
Reaktor 5
Absynth 3
Guitar Rig 2
Kontakt 2
Battery 2
Elektrik Piano
Intakt
Kompakt
B4 II
FM7
Pro-53
Vokator

based on that list im pretty sure 3 is the last os9 compatible version.. except that the musiciansfriend page also says that it requires OS 10.2.6.... osx jaguar required!!! + g4 800mhz cpu - i think it may have been X + 9 both..

we have most of those here on the site but it would be sweet as hell to have it all in one "komplete" installer to be able to install them all at the same time

here are the komplete 3 system requirements:
« Last Edit: July 16, 2015, 08:07:20 PM by chrisNova777 »

Offline Metrophage

  • Consistant Contributor
  • ***
  • Posts: 127
Re: early versions of NI Komplete?
« Reply #5 on: May 30, 2016, 10:58:22 AM »
I just re-installed Komplete 3 a couple of weeks ago, and it definitely was not OS 9 compatible. Some of the installers only work under 10.5-10.6 with a special "Leopard patch", so the sweet spot for K3 is probably MacOS 10.2-10.4.

I was amazed to remember what utter shite the old Service Center was! When I installed Komplete 8, I had every thing installed, registered, and updated within a couple of hours - and most of that time was just loading the Kontakt library. Doing the same thing with Komplete 3 took me a whole weekend of faffing about. I had to manually. It wouldn't automatically authenticate the older instruments like FM7 and Vokator. And it was trying to update Reaktor to a version too recent for the OS - latest is 5.94, but 10.6 tops out at 5.8. As installs go, K3 on 10.5 or later has been a painful experience. But it runs fine after that.

IIRC Komplete 2 could install on OS 9, but I am not sure.

Offline Metrophage

  • Consistant Contributor
  • ***
  • Posts: 127
Re: early versions of NI Komplete?
« Reply #6 on: May 30, 2016, 07:13:21 PM »
That picture above of all of the Komplete versions is from a blog which features an exhaustive amount of information on the various versions of Komplete.

http://blog.ultimateoutsider.com/2014/09/the-complete-history-of-komplete-all.html

They collected all of their info into a giant spreadsheet of every release, what software and versions were included, the date, price, etc.

https://docs.google.com/spreadsheets/d/1C2lEubeNV6OzUnj5o8o6pBPU_jGgzeCALNTLOnoPxeA/edit?pref=2&pli=1#gid=0

But, alas, there is no "system requirements" breakdown of what OS can run what.

Looking at this, my guess is that if any version of Komplete was available for OS 9, it would have only been Komplete 1, because this is the only version for which every program runs on OS 9. Komplete 2 includes Intakt and Reaktor 5, which were OS X only, and the package was upgrade with Battery 2, which was also OS X only.

IMO the best deal for buying an old version of Komplete is 3, because it still includes most of the good discontinued stuff like B4, FM7, Intakt, Pro53, Spektral Delay, and Vokator. As well as being the first to include Guitar Rig. I bought it for cheap from somebody and used it to upgrade to Komplete 8 for cheap. The only drawback is that the legit Kontakt only opens legit sample libraries.

Offline DieHard

  • Administrator
  • Platinum Member
  • *****
  • Posts: 1257
Re: early versions of NI Komplete?
« Reply #7 on: May 30, 2016, 08:32:08 PM »
I rely heavily on K8 Ultimate and some other individual plugs, in runs rock solid with logic Pro 9 and OS X 10.8.5 :)

Every Mac OS X above 10.6 has issues, anything above 10.8.5 becomes almost unusable for my DAW setups

Offline geforceg4

  • Vault Members
  • Platinum Member
  • ***
  • Posts: 535
  • i did my time on mac os 9
Re: early versions of NI Komplete?
« Reply #8 on: July 05, 2016, 03:40:18 AM »
every mac os x below 10.6 has huge issues too tho  :o in terms of software compatibility.. unless u are using your "old softwares" together which u have hardware dongles for