Author Topic: Anyone have an Energy Saver control panel newer than 3.0.5?  (Read 1588 times)

Offline nathan

  • Member
  • *
  • Posts: 2
  • new to the forums
Anyone have an Energy Saver control panel newer than 3.0.5?
« on: March 05, 2015, 06:40:54 PM »
I recently installed OS 9 on my Late 2004 iBook G4. It runs great except for one thing: no suspend. This is a known issue, and people are (somewhat) actively working on it. However, I heard from one of the users on the thread at ThinkClassic that he's experienced the same sleep symptoms that iBook G4 OS 9 users are on late dual USB iBook G3s without their special version of the Energy Saver control panel. This brings me to my point. If you have any OS 9 installations for anything with an Energy Saver version later than 3.0.5, or the special "iBook G3 Energy Saver Control Panel" can you please upload it somewhere?

Offline MacTron

  • Global Moderator
  • Platinum Member
  • *****
  • Posts: 1918
  • keep it simple
Re: Anyone have an Energy Saver control panel newer than 3.0.5?
« Reply #1 on: March 06, 2015, 08:25:25 AM »
what kind of G4 CPU this "Late 2004 iBook G4" does it have?
... a 7447 I guess....
Please don't PM about things that are not private.

Offline nathan

  • Member
  • *
  • Posts: 2
  • new to the forums
Re: Anyone have an Energy Saver control panel newer than 3.0.5?
« Reply #2 on: March 06, 2015, 10:33:31 AM »
It's a 7447A which needs an Open Firmware hack to boot into OS 9. Interestingly, unlike iMic's iBook, which does some kind of Sleeping Beauty thing where it goes to sleep but needs to be hard reset to wake back up, mine just says that the software required for suspend isn't there. It looks like the install disk I'm looking for used to be on Macintosh Garden, but it's now removed.
« Last Edit: March 06, 2015, 10:52:33 AM by nathan »

Offline MacTron

  • Global Moderator
  • Platinum Member
  • *****
  • Posts: 1918
  • keep it simple
Re: Anyone have an Energy Saver control panel newer than 3.0.5?
« Reply #3 on: March 06, 2015, 12:56:28 PM »
It's a 7447A
Quote
mine just says that the software required for suspend isn't there. It looks like the install disk I'm looking for used to be on Macintosh Garden, but it's now removed.

The software you need is "Apple CPU plugins". Unfortunately Most of the 7447 and 7448 CPUs can't boot with this module installed.
Please don't PM about things that are not private.

supernova777

  • Guest
Re: Anyone have an Energy Saver control panel newer than 3.0.5?
« Reply #4 on: March 06, 2015, 08:11:42 PM »
nathan u should be glad it works at all!!
as mactron has pointed it out.. if u enable that plugin u "need" u will lose hte ability to boot up ;)
so i guess u will have to do without suspend
this type of tolerable "issue" is normal for "unsupported" configurations
u win some u lose some.. but the fact that it is even working is a miracle